BMW Forums : BimmerForums banner
1 - 11 of 11 Posts

·
Registered
Joined
·
27 Posts
Discussion Starter · #1 ·
hopefully can get some advice about a couple of probs with my 1996 320i con. first one... steering wheel started going stiff and creaking sometimes, (sounds like my bits ... lol) my guess is steering wheel oil.. but cant find the spot where I put it in, in the engine... any ideas/photos of what it looks like then that would be great!
Also, hood has stopped wanting to work, I think i may have knocked something/switch? putting stuff in the boot? Any help appreciated. Cheers John
 

·
BFuk Legend
Joined
·
11,712 Posts
morning mate
Power steering resivour is on the righthand side of your engine at the front, black bottle, if unsure just follow the pipes up from the steering rack, hope this helps:thumbsup


Cheers
100% Correct Rjb :thumbsup
It sounds like the PAS pump is failing. Check the steering fluid first and if it is full you will need a new pump :frown

I have also re-titled your thread to comply with the forum rules. :cool
 

·
Registered
Joined
·
27 Posts
Discussion Starter · #4 ·
Thanks guys, any ideas for getting the soft top back in action...? Its up, and just suddenly didnt want to work when I came to put it down... so presume something got knocked (in the boot?) or so I have been advised. I was hoping it wasnt the motor! ;o(
 

·
Registered
Joined
·
27 Posts
Discussion Starter · #7 ·
Cheers, BMT, any ideas what i do once I expose the motor..>? I had a look at this a while ago, Im about level 2, when it comes to anything to do with motors... so any remedies helpful... ie: what would you do.. ?
RE: clarke 988, cheers pal, what happens if I pull the red lever? might it solve it? Cheers... wouldnt mind getting it sorted due to hot weather,... and cant really afford to be held over a barrel at any garage...
 

·
Registered
Joined
·
225 Posts
this is really only intended for emergency raising of the roof and not lowering as the rear roof cover doesnt lock and you dont want your roof trying to raise itself at 60 mph on the motorway :D
 

·
Registered
Joined
·
27 Posts
Discussion Starter · #10 ·
yeah, fair point, i am looking at checking the fuses, but have cant find my manuals, anyone any idea where I can download a manual, or details of the fuses for my motor?
Cheers
JOhn
 

·
Registered
Joined
·
39 Posts
It could be worth checking that the switch in the boot lid that tells the hood the boot is shut is working. I've had the problem a few times with the boot not shut properly and thinking the hod is totally dead!
Not sure which of the switches it is, but check them all.
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top