BMW Forums : BimmerForums banner

1 - 17 of 17 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter · #1 ·
well as im not insured on my car yet i had it driven back to mine about 4 weeks ago and it hasnt been started since. so anyway i went to start it today and it just made this clicking noise. i presume that its the battery is dead, so i went and bought some jump leads from halford rated up to 2000cc and tryed to jump it with no luck, it just wont go. just makes a clicking noise. i kept trying through out the day with no joy. my alam just started to go off but soon died out cos it has no juice. does this mean the battery is completly dead and i should buy a new one or could it be something else? the car was starting and running fine before. if i do need a new battery is there any particular one i should get? thanks
 

·
Registered
Joined
·
2,255 Posts
Battery has probably died completely being stood in this cold weather. I had a batter that ran fine one day, was dead the next!

Do any of your lights on the instrument cluster light up to any extent?

Ideally, you want to out a battery tester on it (they are not expensive to buy) or get the AA/RAC to come out as they will be able to to confirm how far gone the battery is. A new battery (i paid £35 for one from Eurocarparts) is the first step though.
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #3 ·
:D thanks m8, thats reasuring. well the dash lights came on verrrrry dim but when after trying to start it they went out completly, even when the alarm went off the hazzards were flashing dimmer and dimmer until they went out and the sound went lol. 35 quid thats cheap. could you get me a link or phone number? thanks for your help, this cold seems to be ruining everything :mad
 

·
Registered
Joined
·
2,255 Posts
:D thanks m8, thats reasuring. well the dash lights came on verrrrry dim but when after trying to start it they went out completly, even when the alarm went off the hazzards were flashing dimmer and dimmer until they went out and the sound went lol. 35 quid thats cheap. could you get me a link or phone number? thanks for your help, this cold seems to be ruining everything :mad
I'm sure your battery has completely had it to the point where it cannot be revived.

I'll post a link for eurocarparts
 

·
Registered
Joined
·
2,255 Posts
http://www.eurocarparts.com

if you go to parts, youcan select your vehicle and you can sift through all the parts and prices specific to your car.

I just got the Lion battery, ECP has been doing them for years. They also do Bosch @ very good prices.

GSFCP wanted £75!
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #6 ·
ar cheers m8. another question lol. mine has the 1896cc engine, is that the m42 or m44. or will the batt be the same either way. nice 1
 

·
Registered
Joined
·
2,255 Posts
ar cheers m8. another question lol. mine has the 1896cc engine, is that the m42 or m44. or will the batt be the same either way. nice 1
Can't help you with that (I'm not clued up on the 4cyl cars).

Just go to the parts section of the website as that will state your options. Alternatively give your local branch a call in the morning and give them your reg or chassis number and they should be able to to confirm.
 

·
Registered
Joined
·
46 Posts
Hi Mate, just to put your mind at rest a little more... Previously to the 5 series I has a Subaru Impreza Turbo and the Battery went flat in that... I thought I'd jump it from the missuses car, at the time and escort diesel, and the scoob wouldn't start from that, just clicked, got my friendly mobile mech/scoob specialist out thinking something was horribly wrong and he bought a spare battery with him connected jump lead to that and it started immediately... anyhow that's my story... hope you get it sorted soon!
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #12 ·
yes i was trying to jump it from a 08 plate 1.9 td astra van. thanks for the help guys,will up date when i get it sorted.
 

·
Registered
Joined
·
1,423 Posts
I would have expected to be able to jump start from a good car using a good set of leads, unless there's maybe a problem with your battery.
Worn starter motor brushes can give the same symptoms in case you still don't get to the bottom of it:thumbsup
 

·
Registered
Joined
·
40 Posts
i have in the past left the running motor hooked up to the dead battery for a good ten minutes and then turned the engine, little fiesta to a 2ltr diesel. it worked

you could remove your old battery get a good priced charger, maintain it and use it as a spare for next time.
 
1 - 17 of 17 Posts
Top