BMW Forums : BimmerForums banner

1 - 18 of 18 Posts

·
Registered
Joined
·
262 Posts
hi mate,
welcome to owning a 320i:lol
i have the same mate and its just how they are, prob the slowest bm you can get but it sounds ok tho and the drive is good but if you are after a quick bm im afraid you wont get it with the 320!!
 

·
Legendary BFuk Member
Joined
·
12,959 Posts
could be one of your pipes (air pipes) has a split, check your rubber boot to throttle that is a common fault
Great advice here:thumbsup

If no joy here then a diagnostic scan would be worthwhile as it could be a number of things from coil packs starting to break down, cam/crank sensors on their way out etc.

There is also a small one way valve incorporated into one of the systems. I don't know what it's called but Ronnie may understand what it is i'm trying to describe??? I've replaced one before and noticed a dramatic increase in performance.

Let us know how you get on?
 

·
Registered
Joined
·
8 Posts
Discussion Starter #7
What year is your car?
its a 1992, its in mint condition but it bugs me cos sometimes it runs great then others anything below 2000 rpm it can stutter, i had all the plugs replaced but have a feeling the coils might have somethin to do wit it, if so how cheap coul they be replaced? tankyou:hihi
 

·
Registered
Joined
·
8 Posts
Discussion Starter #8
hi mate,
welcome to owning a 320i:lol
i have the same mate and its just how they are, prob the slowest bm you can get but it sounds ok tho and the drive is good but if you are after a quick bm im afraid you wont get it with the 320!!
im so glad you said that, i wouldnt agree its that slow, ive had slower but it was bugging me lol :rofl only problem is the grindin noise from the rear right tyre, next job, woo woo :hihi
 

·
Registered
Joined
·
20,393 Posts
Could also be Lambda sensor, it would be best to get the codes read and then we will have a better idea
 

·
Registered
Joined
·
113 Posts
had the same problem mate with my 93 320 terrible low end power when i brought it low idle speed and stuttering when pulling off

the work iv had done so far is cam sensor likely to cause the stuttering at pulloff and mine wouldnt redline in any gear

lambda sensor obveously will drink the fuel do you smell petrol while standing by exhaust?how many miles per gallon do you get?

rear wheel bearing sounds like yu have the same prob lol

and recently found an airleak in the rubber boot

since having this work done the car is completly different by no means super fast but alot better to drive with better low end power and 25mpg 20 if canning in sport as mines auto with isnt too bad from the 12 i used to get average!

like boostist said get the codes read first and check for airleaks as ronnie told me the 02 lambda can show up if theres air leaks and you dont want to be paying for that if its not needed hope this helps
 

·
Registered
Joined
·
113 Posts
also what is this one way valve you mentioned a20 rym and where in the sytsem is it? or could ronnie please open up on the subject ;-)
 

·
Legendary BFuk Member
Joined
·
12,959 Posts
It has a thin pipe going into it and coming out of it. If I recall correctly it's towards the rear of the engine bay slightly off to the right. Same sort of area as the water hoses that go through the bulk head to feed the heater matrix.

One half is black and the other half is white, it's smaller than a golf ball in size.

What's the last 7 digits of your chassis number? I'll see if I can dig it out on www.realoem.com for you:thumbsup
 

·
Registered
Joined
·
8,981 Posts
The one way brake vacuum valve is sitting just the far side of the throttle.

You'll see an inch and a half of cotton overbraid hose, the valve which is half black / half white as mentioned, and this then has a hose that runs off to the brake servo.

Hard to say if that is the problem though
 

·
Registered
Joined
·
284 Posts
thanks very much.... A quick question for you tho TheEnd when i brought the car the matey told me it had been chipped, so all the way up to about 3000 it feels kinda driving the compact ! ! but then at 3100 it starts takin off lol is there anyway to decipher what chip i have ?

and any other tips for gettin the best out of her?
 

·
Registered
Joined
·
284 Posts
how do i get inside the ECU ? ? lol i think this one has but cant be too sure any pics or walkthroughs ?

if there is just the normal bmw chip or a cheap ebay jobby how much for one of your special ones lol ? e36 320i se j652 egc - if that helps
 
1 - 18 of 18 Posts
Top