BMW Forums : BimmerForums banner

1 - 16 of 16 Posts

·
Platinum BFuk Member
Joined
·
820 Posts
Discussion Starter #1
Hi everyone,
Im after a bit of advice, I want to get a new head unit, as my old Sony CDX-F5500 is starting to jump when I go over bumps.
Im not very clued up when it comes to car stereos, but the main thing Im after is that it fast forwards and rewinds MP3 files quickly, as I listen to a lot of hour plus sets as MP3s and mine is dead slow.
Any reccomendations around that price range?
Preferably equal or better spec than my current one.
Cheers, Steve

Edit: Not bothered about connecting an MP3 player or anything like that, as long as it works with my amp Ill be happy:thumbsup
 

·
Platinum BFuk Member
Joined
·
261 Posts
Something like this mate you cant go wrong woth . Good price good name . And good looking unit to boot. The 24 bit burr brown processor kenwood use just now is awesome . Click me .
Might even find it cheaper on flea-bay
 

·
BFuk Legend
Joined
·
11,712 Posts
You will need a BMW to ISO adapter lead. It makes life a lot easier than hard wiring it in. It can be a struggle to get the head unit back in after though. I always remove the glovebox so i can get my hand up behind and feed the wires in.:thumbsup
 

·
Platinum BFuk Member
Joined
·
820 Posts
Discussion Starter #6
Nice 1 m8, Im assuming theres one already connected to the back of my Sony head unit (it was in the car when I got it) will that one work or will it need to be a Kenwood specific lead?
 

·
BFuk Legend
Joined
·
11,712 Posts
Hopefully there will be an iso block connected to the sony which will save you a couple of quid. The lead for the kenwood comes with the stereo:thumbsup
If you can pull your old stereo out for me, dont bother disconnecting it but take a pic of the wiring and post it up then pm me and ill let you know what you will need mate.:thumbsup
Hopefully nothing, but you can never be sure. i had some right horrors with previous wiring jobs in my 318.:jaw-dropping
 

·
Platinum BFuk Member
Joined
·
261 Posts
If im not mistaken the sony and kenwood ISO`s are the same , at worst the permanent and ignition lives will be wrong way round but holding the plug in place you will be able to tell if the yellow and red wires go to the same places in the ISO . As posted previously by Steve, a picture would confirm this .
Thats a picture of the wiring not of a day out at Bognor regis.
 

·
Platinum BFuk Member
Joined
·
820 Posts
Discussion Starter #11
Any news on the stereo mate? :D
Not yet m8,still debating which one to get, what speakers to put in the footwells, still waiting for my m3 mirrors (which will need painting when they arrive) and black grill to come through the post, need some work doing on my arches, its all just too much at the mo,:wide-eyed:eye-popping:yikes:hihi

ill let you know when its done and put some pics up m8:thumbsup
 

·
Platinum BFuk Member
Joined
·
261 Posts
Oh the joys of motoring , i MOT`d my wifes compact last week and i think for the 1st time in my life i ever had a car fly thro an MOT . Great i think , £45 for the ticket and no repair bills.
This week the heater matrix goes in her car , probably a bill of around £400:jaw-dropping
As i said , the Joys of motoring....
 

·
Platinum BFuk Member
Joined
·
820 Posts
Discussion Starter #14
Well Ive put my search on hold at the minute...

Took my car to an auto electrician to fit my front components, as Im clueless with electrics and he said the reason its like its jumping is because whoever fitted the head unit (before I got the car) had left loads of loose wires behind the dash:jaw-dropping which was causing it to short out over bumps.
It hasnt done it since he sorted it, so no need to but a headunit just yet... thanks for your reccommendations though:thumbsup:thumbsup
 

·
Registered
Joined
·
401 Posts
if it was shorting it would pop a fuse, pull the stereo out and take a pic of how the wires are connected, if it is shorting then there isnt an iso block attached and it will have to be wired up manaully, this is an easy job and i can talk you through it no worries, a pic of the wiring as it is now will help tho.

all stereos now have a certain colour code, black is ground(negative) red is power(plus) yellow is memory(backup plus) and blue is the auto aerial wich you wont need, the rest are for the speakers, so if you pull the stereo out and look at wich of those wires connect upto, ie if the black connects to a brown then brown will be the earth, on the stereo black is earth, black is connected to brown on the car so brown on the car is earth, make a note of all the wires and then fit the new stereo jsut the same, black to earth on the car etc, then the speakers are dead easy, wire them up untill a speaker comes on, usually you will have a blue and a blue with white stripe, they go together, white/white with blackstripe go together, the wires in the car will be the same so just link them up 2 at a time to determine wich is the correct wires for each speaker, and hey presto your done

just read your post again, didnt see the fixed part, here is a guide on what to do if you wanna do it yourself tho.
 
1 - 16 of 16 Posts
Top