BMW Forums : BimmerForums banner
1 - 10 of 10 Posts

·
Registered
Joined
·
401 Posts
Discussion Starter · #1 ·
ok so ive just had my e34 back of my mate who was borrowing it and its got a weird vibration, basically from take off through to around 2 and a half thou its got a vibration that gets worse as the revs build and then it goes away over 2 and a half, im thinking propshaft as it dosnt affect the car in anyway handling wise but it does shake the car a little, its just the same wether its at normal revs or a more spirited start.
i cant feel anything in steering or braking and it still drifts a treat but that vibration is there and its quite annoying, the car is going back to my mate soon but id rather get it fixed while ive got it on my drive, anything i should look at or consider, ive never messed with propshafts or diffs so have no clue what anything is but if someone points me in the right direction ill work it out.
 

·
Banned
Joined
·
478 Posts
Join the club ron!:frown,

My propshaft is a little worse than yours but basically does the same as yours,

The vibration definately seems to come from the middle of the car??

To remove the prop, or to get access to it, as i have discovered, you will have to remove the exhaust. Check the rubber coupling (guibo) for cracks, and centre bearing/centre coupling for play.

Im doing mine over the next few weeks, and i will be posting pictures of the job as i go on, so maybe that might help you when i come to do it?.... :thumbsup
 
  • Like
Reactions: Ronnie

·
Registered
Joined
·
14 Posts
Hi All...

Any update on this..?
I recently got new rims and tyres fitted to my 520I and then had a 4 wheel alignment on them done. I was on the motorway yesterday and when ever I went between, 55/ 60 MPH the steering wheel would shake. Not violently but enough to make you think... It only happened exactly at those speeds. It would happened very occasionally before I had the wheels changed.
should i go back to the garage, could the alignment need re-doing...?

Many thanks

Matt
 

·
Registered
Joined
·
710 Posts
Hi All...

Any update on this..?
I recently got new rims and tyres fitted to my 520I and then had a 4 wheel alignment on them done. I was on the motorway yesterday and when ever I went between, 55/ 60 MPH the steering wheel would shake. Not violently but enough to make you think... It only happened exactly at those speeds. It would happened very occasionally before I had the wheels changed.
should i go back to the garage, could the alignment need re-doing...?

Many thanks

Matt
You seem to be suffering with the E34 Shimmy.

More information and solution: http://www.bmwe34.net/E34main/Maintenance/Suspension/Upper_arm.htm




ok so ive just had my e34 back of my mate who was borrowing it and its got a weird vibration, basically from take off through to around 2 and a half thou its got a vibration that gets worse as the revs build and then it goes away over 2 and a half, im thinking propshaft as it dosnt affect the car in anyway handling wise but it does shake the car a little, its just the same wether its at normal revs or a more spirited start.
i cant feel anything in steering or braking and it still drifts a treat but that vibration is there and its quite annoying, the car is going back to my mate soon but id rather get it fixed while ive got it on my drive, anything i should look at or consider, ive never messed with propshafts or diffs so have no clue what anything is but if someone points me in the right direction ill work it out.
Broken engine mount could cause a vibration through the car.
Prop shaft centre bearing could also cause a vibration through the car.

E34 shimmy would, but that would be noticeable through the steering.

Warped disc, which the E34 apparently suffers with, could also cause vibration if it were the rear discs.

Have one in the garage that suffers from the Shimmy, so can vouch for the above.
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top