BMW Forums : BimmerForums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
100 Posts
Discussion Starter #1
Hi,
I need some help, my 318is coupe was driving fine last week, then i went away for a long weekend and left it standing not being used at all for 4 days. When i was on my way back I noticed a loss in power every now and then on the motorway, but it would pick up and start working again. It has been happening every now and then since, is there any fix for this, as if it happens on a rounderbout when pulling off it could be nasty.

Thanks,
James
 

·
Registered
Joined
·
82 Posts
hi mate i have had a similar issue. i went an got my codes read last week. it threw up throttle position sesnsor fully open. i have changed mine and it seems abit better but the guy also told me my fan was locked on. thats why it sounds like a jet tacking off.

what i would sugest is give your maf throttle and icv a good clean with some carb cleaner and check all your hoses for any splits and airleaks.

hope this helps
 

·
Registered
Joined
·
82 Posts
also i discovered yesterday when i stripped my throttle and inlet manifold i had a knackered ht lead. changed it an it idles much better. also have slightly more power.
 

·
Registered
Joined
·
100 Posts
Discussion Starter #4
Thanks for the help, i've given the throttle body a good clean and used some fuel injector cleaner added to the petrol. Just took it out for a drive and seems to be running fine now. I'm hoping I have fixed the problem, but i'm going to see what happens in the next few days.

James
 

·
Registered
Joined
·
625 Posts
Carb cleaner or brake cleaner is ideal spray it onto the wire from a distance (in other words don't blast it) as these are sensitive. Do a couple of times and replace :)
 
1 - 7 of 7 Posts
Top