BMW Forums : BimmerForums banner
1 - 19 of 19 Posts

·
Registered
Joined
·
29 Posts
Discussion Starter · #1 ·
all the dash lights come on and then go off when i drive along, like ive just turned the ignition on.... why is this? ive only noticed it at night when the lights are on but im not sure if its only because its dark and they stand out more, so they could be coming on in the light. any one experienced anything like this before???????
 

·
Registered
Joined
·
29 Posts
Discussion Starter · #6 ·
no not realy, just kind of happens. someone told me it could be that during its life its had a big bunch of keys hanging from the barrel constantly causing a weak connection in the barrel?????
 

·
Registered
Joined
·
20,393 Posts
no not realy, just kind of happens. someone told me it could be that during its life its had a big bunch of keys hanging from the barrel constantly causing a weak connection in the barrel?????
Unlikely as the switch is what does the connection and it's right at the rear off the barrel
 

·
Registered
Joined
·
564 Posts
Get your sterring cowling off mate and inspect the wiring and plug that go in to the bottom of your barrel. the plug should be satin place and held in by 2 small allen key screws
 

·
Registered
Joined
·
51 Posts
Hi Guys, I just wanted to point out that I have a near identical problem on my 1993 325i Auto but with mine I lose everything on the dash including all the gauges (just like turning the ign off and then on again) and the problem only occurs in damp weather (i.e. not in the summer). I've had the cluster out and that looks fine, i checked the fuses and connections and they seem fine and it seems to have no consistency, it doesnt do it over bumps or anything. I've exhausted all I can and the nature of the problem makes me believe its a poor contact on a relay but apparently the dash has no relays, any ideas??

Cheers
 

·
Registered
Joined
·
11 Posts
E36 320i auto - dash lights go off

Hi Guys, I've got exactly the same problem. I'm going to try and investigate over the weekend. Mine's an E36 320i Coupe Auto... I've checked fuses etc, but nothing. It's getting progressively worse now though. Sometimes it never happens and other times it disappears for a couple of minutes at a time...
 

·
Registered
Joined
·
29 Posts
Discussion Starter · #14 ·
oh good, im glad its not just me! it happened loads tonite! lets do some investigation and see what we can come up with then...
 

·
Registered
Joined
·
650 Posts
All these cars are AUTOs? Could any of the auto box wiring cause this? Just throwing an idea out there....
 

·
Registered
Joined
·
45 Posts
..

sam let me have a look.. you wont sort it on here..:D

im down in two weeks so wait..

i had the same in my bmw ill have alook at yours.. mines all fixed now...:lol

steve...
 

·
Registered
Joined
·
20,393 Posts
sam let me have a look.. you wont sort it on here..:D

im down in two weeks so wait..

i had the same in my bmw ill have alook at yours.. mines all fixed now...:lol

steve...
:shifty:


The Following User Says Thank You to wolfman For This Useless Post:
Ronnie (Today)


:rofl
 
1 - 19 of 19 Posts
Top