BMW Forums : BimmerForums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
29 Posts
Discussion Starter · #1 ·
right, ill explane from the begining.... i bought a 1993 320 auto off a mate. it had been stood for a few months prior to me collecting. when i took the car away we needed to put on the jump pack to get it to start but it fired up straight away, no probs! then as i drove from his house to mine it kept cutting out (not stalling, just juddering) like it was out of fuel. so i stuck a load a fuel in and it started again no problem. when i finally got to my road (about 1.5miles from his) the car back fired once and kept coughing still so i pulled onto my drive and shut it off. next day went to start it and it took ages, turned over for a few minutes before starting, of which it did not want to do at all (i mean it didnt just burst into life when it eventually started, i took a good few more turns and then it just about started). after it started it ran like a dream, idled perfectly! however if you boot it it would cough and splutter then rev up, just like its bogging down. after this i left it to idle hoping it would clear its self but it didnt, it just died like it ran out of fuel!

now ive put a new crank sensor on it as that was a fault code i had and now thats cleared. done another diagnostic on it and its all clear, done a live data test and thats all A-OK. checked fuel pump/ecu relays and they are all fine, checked (visual) ecus in bulk head (prone to getting wet???) and they are all good..... got any ideas of what the problem could be yet????? well heres something else to add to the problem

the plugs are wet and stink of fuel (however the injectors are pulsing fine)
if you take out a plug and stick it in the coil pack against the block, you get a good spark.
ive got good compression (not tested it yet but you can here its got good compression)
tried using easy start but it didnt even what to know that....

what the F#&K could it be!!!!! ive ran out of ideas and its really getting me down just looking at the bloody car! any suggestions are more than welcome as i just want this sorting now! :frown
 

·
Registered
Joined
·
20,393 Posts
Have you checked all hoses for splits? any split engine induction pipes/engine breather pipes/vacuum pipes will give you trouble
 

·
Registered
Joined
·
29 Posts
Discussion Starter · #3 ·
but surely it wouldnt make it totally not run, not even cough would it??? even with easy start, not even a wisper...
 

·
Registered
Joined
·
20,393 Posts
but surely it wouldnt make it totally not run, not even cough would it??? even with easy start, not even a wisper...
It should try to fire up but it's not the point, if you know everything is tip top and have checked everything then it gives me a better idea of what you have done, if I was there I could probably tell you straight away what the problem was, but sitting on the end of a computer makes it tricky, hence the questions :hihi
 

·
Registered
Joined
·
29 Posts
Discussion Starter · #5 ·
alright then. ill check all the hoses and everything tomorow for any sort of leaks or defects and let you know, im pritty sure their though. what would you suspect if their isnt any???
 

·
Registered
Joined
·
292 Posts
water in the fuel lines (condensation in fuel tank) due to being stood possibly,assuming it was running ok before being stood
 

·
Registered
Joined
·
29 Posts
Discussion Starter · #8 ·
water in the fuel lines (condensation in fuel tank) due to being stood possibly,assuming it was running ok before being stood
but it doesnt fire on easy start so i wouldnt think this would be the problem would it? also ronnie, i checked for air leaks and have nothing... all good! would the air flow meter come up on the diagnostic test?
 

·
Registered
Joined
·
20,393 Posts
but it doesnt fire on easy start so i wouldnt think this would be the problem would it? also ronnie, i checked for air leaks and have nothing... all good! would the air flow meter come up on the diagnostic test?
Only if completely buggered

We used to grab one of the shelf(spares) and give it a try :frown

Otherwise it can be monitored in live data on a diagnostic scanner.

Do you have a Siemens ECU or Bosch?
 

·
Registered
Joined
·
29 Posts
Discussion Starter · #10 ·
im not sure what ecu i have im afriad. where abouts are they and how many are their? we done a live data test on it and it come back fine... this is one major pain in the arse which is proving abit of a challenge
 

·
Registered
Joined
·
29 Posts
Discussion Starter · #12 ·
yeah we did check it over but i wasnt sure if their were any more in the car at all. but if its only them two the ill check for the make.
 
1 - 12 of 12 Posts
Top