BMW Forums : BimmerForums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
hi all,very new to site and wondering if anyone can help.my fuel light is always on and shows empty even when full,have had fuel sensor checked and all seems ok as well as earth and live under rear seat,and have had the connector to back of gauge checked that its plugged in is there anything else i can get checked im reallly not mechanically minded,i only know how to drive cars not fix them:embarrassed:embarrassed:embarrassed
 

·
Registered
Joined
·
183 Posts
try disconnecting the battery for 5 minutes and then reconnect it and see if that works. mine was doing that aswell but my temp guage wasen't working as well and that fixed mine.
 

·
Registered
Joined
·
20,393 Posts
Try a binnacle test and see if the gauges go up

Hold down the mileage reset button with the ignition off, turn the ignition key to position 1, Wait for TEST to appear and then release reset button, watch as the binnacle does a self test.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #4 ·
hello again,have tried disconnecting battery but has not worked and have also done what ronnie said about checking dials and when i do this all the dials move including fuel gauge,so in respect of this what does this mean or what is next step.thanks
 

·
Registered
Joined
·
11 Posts
watto19, how exactly did you go about measuring the level sensor? Did you check the resistance? See diagram for probe points.
 
1 - 7 of 7 Posts
Top