BMW Forums : BimmerForums banner
1 - 11 of 11 Posts

·
Registered
Joined
·
57 Posts
Discussion Starter · #1 ·
Hi i'm posting this on behalf of my dad
he has as stated above an e30 325
he's just had the car returned from a local body shop after being painted the car was running when we dropped it off but now its home again it wont start
we've sigled it out that is not getting fuel through so we
checked all fuses (ok)
so we got the haynes manuel out and bridged the fuel relay it fires first time but wont tick over (but it has had the battery off for quite a while and i know bmw's can be tempremental like that)
weve put a new relay in and it is back to square one wont fire again and the haynes doesnt go into any more detail as to what it could be
so any help or advice would be greatly appreciated
thanks paul
 

·
Registered
Joined
·
1,423 Posts
So fuse 11 is ok and there is 12v getting to the pump when you bridge out pins 30 and 87 on the relay, and you've fitted a new relay.
Check for +12v at pin 86 on the relay base with the ignition on. If there's no voltage it may be a faulty main relay Can you hear/feel the main relay click when you turn on the ignition?
 

·
Registered
Joined
·
57 Posts
Discussion Starter · #10 ·
hi everyone thanks for all your help so far
we've had an auto sparky out to the car today and he seemed to think the ecu was at fault so we removed it to find one of the pins was bent double and squashed against an adjacent pin so we assume that when the car was getting welded they have removed the ecu and upon replacement used a hammer:confused
we have since straightend the pin out put it all back together and it still doesnt run unless we supply the fuel relay with an earth the sparky left saying the ecu was at fault because it isnt supplying the relays with an earth and reccommended we get another ecu to try but that to me seems an expensive/hard to get part just to try do you guys have any idea s
thanks paul
 

·
Registered
Joined
·
57 Posts
Discussion Starter · #11 ·
it's alive

me and my dad have managed to get a replacment ecu for the car £16 (god bless ebay) plugged it in and without even trying the car fired up and is running like a dream
i'd like to thank everyone for there help and advice cheers fellas
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top