BMW Forums : BimmerForums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
BMW 325i E30 Touring M20 12/1988. Cylinders full of petrol - engine turn over blocked - rock solid. Taken out plugs and petrol sprays out of plug holes when momemtarily activating starter motor. Can hear petrol spray into cylinders when ignition turned on. Took of electric supply rail to injectors and with ignition turned on, I measure 12v on all 6 injector sockets. I don't think that should be so - I think they should start cycling to the firing order when starting, and not have a constant 12v supply to all 6 injector with engine not running. Plug on harness under intake manifold already dealt with years ago and checked again now - OK. I guess this hasness ends up in the DME control box, which I think is situated above pedals in RHD's. Is that where the problem is, and can one do anything in that box? What do I do next? Any suggestions are very welcome.
 

·
Registered
Joined
·
271 Posts
Not tested a BMW before but all injectors I have seen are sync switched, in other words they have 12v permenent and the ecu switches the earth.
If all 6 are stuck open I would say its ecu related, either an ecu fault or power supply to the ecu, on loss or 12v to the ecu all out puts sync to earth by default quite commonly, if the 12v is on the injectors due to the ignition being on then this will open all injectors to 100% duty, and switch all other outputs too.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top