BMW Forums : BimmerForums banner

1 - 20 of 30 Posts

·
Registered
Joined
·
43 Posts
Discussion Starter · #1 · (Edited)
Hello i have a bmw 325e 1987 car starts fine and i drive awhile then car seems to flood out , i pull over and let car sit about 1 or 2 minutes restart car runs fine , i do this very often , could it be bad injector , fuel pump , i installed new hoses ect.. too . i give gas and just floods out , very wierd tbh , in advance thnxz ;)
 

·
Registered
Joined
·
43 Posts
Discussion Starter · #3 ·
no lose of power , i pull over and put car in park it idles fine and accelerates fine too does flood.
 

·
Registered
Joined
·
43 Posts
Discussion Starter · #7 ·
it clogs out putters like , i pull over turn off car , wait 1 min restart car runs fine for a few miles or a day or two some times
 

·
Registered
Joined
·
43 Posts
Discussion Starter · #9 · (Edited)
hmm tbh i hav'nt gone on a long drive yet , but it run's g8t when it's not doing it , it has power i give gas it fly's , just when i take foot off gas at times it putters like floods out , i go slow and it doesnt fix problen so i pull over .
 

·
Registered
Joined
·
20,393 Posts
If when you take your foot off the gas the car tries to cut out then it's got a air leak, If it loses power(go) when driving with foot on the throttle then could be a electrical fault or fuel starvation.

We need you to test it out and post back more info, drive it at speed somewhere safe and see if it does it
 

·
BFuk Moderator
Joined
·
244 Posts
next time take note of temp guage, if problem only starts when temp gets ~ half way, it is the blue coolant temp sensor near the thermostat causing your problem
 

·
Registered
Joined
·
43 Posts
Discussion Starter · #13 ·
Cool guy's i'll drive today and test both u guy's suggestion's and reply asap when i return . Again THANK'S ;)
 

·
Registered
Joined
·
43 Posts
Discussion Starter · #14 ·
update i drove bimmer for a long ride at 75 miles about 20 miles and return home ok nothing happen car ran fine ..... wierd should i clean my icv and if so with what product is good and i read maybe it be also my fuel pressure regulator maybe bad ?
 

·
Registered
Joined
·
20,393 Posts
The idle control valve is always worth cleaning out on a E30 BMW, Throttle body or carb cleaner is good
 

·
Registered
Joined
·
43 Posts
Discussion Starter · #17 ·
Hello , sorry havnt replied back drove car to a family members house to test at a high speed at on highway at 75 mph ran g8t for a whole day ,nxt day i left to go home was fine until i got halfway home car started gaging again ,i gave it gas and car wounld'nt go anyfaster and like it flooded out ,so i pulled ovr and turn off car and let it set for a few miniutes then restarted car drove fine for about 5 to 7 miles then i repeated steps again , i made it home ;) i clean icv now im going to clean mass flow w/crc masss flow cleaner , this car drive's like a charm when it not acting up , i changed oil and filled car up and put in lucas fuel injector cleanr too im going to look for a fuel pressure regulator too, once again thankz ;)
 

·
Registered
Joined
·
43 Posts
Discussion Starter · #18 ·
cleaned icv and massflow and car seems to be bettr ,going to give a test drive in a few to see if all is good .... thnkz again ;)
 

·
Registered
Joined
·
43 Posts
Discussion Starter · #19 ·
same results car doesnt accelorate when i give gas aftr awhile of driving , again i pull ovr and turn off car wait a few minutes and car runs fine , then a few miles down da road car hesatates again ,looks like it does it when car gets warm .. going to do more search , but wont giveup ;)
 
1 - 20 of 30 Posts
Top