BMW Forums : BimmerForums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Hi Guys
Am a newbie to to the 840 and used to the quirks of a 525td and 530d. On first long journey have had the oil warning light come on and cannot read message on OBD as many pixels not working. Engine runs sweet as ever.. it did need a pint of oil to top it up but light continues come on with that 'bong' warning noise! No probs with engine temp. Had to drive 50 miles back home and not a murmur. Any suggestions please?
 

·
Registered
Joined
·
230 Posts
At a guess.... the bong is warning you of low oil level as opposed to pressure, i think pressure would bring up a more urgent alert

When did she last have a service and is she leaking oil, oil stains when you park up etc
 

·
Registered
Joined
·
10 Posts
Discussion Starter #4
Hi Vultch
Know you are a regular conributor..thanks! LAst service 3mths ago.. all lights showing and as I said just took a pint of oil to top up to top level on dipstick and so far no leaks on the drive. Her indoors will soon tell me! Is weird so may just be faulty switch
 

·
Registered
Joined
·
230 Posts
could be an sticking level switch, I recently changed the oil in my old Toyota Hilux, but this time I used an engine oil flush before the new oil and filter, it must have unclogged some gunge as the oil pressure gauge now reads double what it used too despite numerous previous oil changes..
 

·
Registered
Joined
·
10 Posts
Discussion Starter #6
Hi
Thanks. Off to garage in morning to have her checked out. Lost no oil in last 50 miles so hope not serious.
Had a Hilux before too. Is critical to change oil every 5000 miles minimum otherwise the starting becomes a prob.
 
1 - 6 of 6 Posts
Top