BMW Forums : BimmerForums banner

killed

  1. BMW X Series - Tech Talk For All Gen Of X Series
    So, this is my first post here. Please be gentle. ? So, bought me a x5 e70. Two days later particle filter warning. Car in limp mode. Run a scan. Trottle valve actuation problem. And also when I picked up the car. Engine temp only reaced 70° So I replaced thermostat and repaired the throtle...
  2. General BMW Discussions
    I have killed my beloved car Hi there, So a few weeks back I had the 'Low Pressure Oil' symbol come on but disappear within 10 seconds or so. That occurred almost daily and I assumed that it might have been a sensory problem rather than an actual one. So I kept on driving. Last Thursday the...
  3. Car Audio, ICE, Car Alarms, Mobile Phones, I-Drive
    Hi guys, I fitted a Vibe slick 1200w subwoofer into my e46 330ci last weekend. I read up about it and watched the YouTube tutorials. I feel that I've spliced everything correctly into the harman kardon wiring but once finishing and putting everything back together, my new vibe sub and amp are...
  4. BMW 3 Series Forum - Technical Talk on the BMW E21
    Hey y'all. I've got a 94 325is. I was driving home two nights ago and hit a patch of water about 6 inches deep. It splashed up everywhere and killed my car. I left it on the side of the road overnight to dry out and came back the next day. Car still wouldn't start so i pulled the plugs and found...
  5. BMW 3 Series Forum - Technical Talk on the BMW E46
    Guys I finally got the whole hub assembly off and the old bearing out. I fitted the new baering but when I put the hub back in its knackered? Its all wobbly like a knackered one. I used a bearing puller to pull the hub onto the new bearing? I took that one off and tried my second but same thing...
  6. Diagnostic Hardware and Software Discussion forum
    Hello, Having a number of issues. I've posted this else where so I'm going to copy & paste from another forum I now have updated datens but I don't know if I've got them to work properly - as when I last tried I got 'VIN Error'. Afterwards I tried SG_Reset but looks like my ignition won't...
  7. BMW 3 Series Forum - Technical Talk on the BMW E46
    Hi all, first post and it is a problem that is really doing my head in! Hopefully you can give e some advice, here's the story. 1. My starter motor failed so a friend and I replaced it the other weekend. 2. When we connected the battery back up the new starter motor spun up immediately. We...
  8. BMW 3 Series Forum - Technical Talk on the BMW E46
    Right few months ago i was trying to fit LEDs to my car and tried to fit them behind the headlight control switch. (I know its stupid now) Blew the controller up. Then when i tried to drive the breaks didnt work very well. It can be fine at times, but the break pedal will always go hard and...
  9. BMW 3 Series Forum - Technical Talk on the BMW E46
    Right i was attempting to fit some LEDS behind the light switch control for the foot well. Ended up i blew the leds in the switch so now theres no lights on there. Though o well its only a light, then i drove my car down the road and the car breaks at low speeds seem fine, but then over 20mph...
  10. General BMW Discussions
    Ok so the title sounds a bit dramatic but hold on :P So as I sit here and write this message this analog tv transmitter in my local area has just been shut off for good which leaves me with an issue in the dashboard of my BMW. Yes that's right the expensive optional extra that is the TV is now...
  11. BMW 3 Series Forum - Technical Talk on the BMW E21
    So whilst putting the roof down the other day a large bolt got stuck in between the roof flap cover and the roll over hoop jamming the cover in the down position and I hadnt realised when tyring to put the roof up. Needless to say when i pressed the button nothning happend and it took a lever...
  12. BMW Detailing, Bodywork and Styling forum
    As per title. Never washed previous cars with anything butfairy liquid and sponge. Went yesterday and bought microfibre cloths, Autoglym shampoo, Autoglym resin polish, Maguiers NXT wax and pad, more cloths and buckets. Started the whole procss this afternoon at 3 after riding the push bike...
  13. BMW 5 Series - Tech Talk For All Gen Of 5 Series
    hi guys ! any ideas on this problem please? my 530d 2007 was starting all ok until it had a nearside front door changed (with loom swopped over ) and even though the ignition lights up ok, and starter button cranks engine , it wont fire up . i have tried leaving the battery off for 24 hours .
Top