Power loss 2004 320d

Notices
 

Thread: Power loss 2004 320d

Reply to Thread
Results 1 to 2 of 2
  1. Power loss 2004 320d 
    #1
    Bimmer Fan
    Car Details
    srider's Car Details
    Model of Car:
    320d
    Year of Manufacture:
    2004
    Transmission Type:
    Manual
    Car Body Type:
    Touring

    Join Date
    Aug 2013
    Location
    United Kingdom
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hi,

    For a while now I have had loss of power in the top end of the rev range (3-5prm ish). On the motorway the car just does not pull anywhere like it used to. Key to this is that very occasionally the car will come back to life. If it does work again once I switch off and return to drive another day low power returns.

    I got a diagnostic done on it and one sensor near the turbo was changed as it was full of oil. This and a software update improved running a tiny bit, but still low on power. The technician said there was boost pressure reading was too low (not sure how this was measured).

    So the turbo was taken to be the issue. I got a 'new reconditioned one' from Essex turbos (very friendly, good advice and turbo well packed and looked good) and put it in. Also cleaned a clogged up EGR, mechanism seems to still work (thinking of bypassing this, seems to defeat the job of a turbo and intercooler to put in hot exhaust gas to run an engine?!), all the plastic manifolds cleaned, (about 1mm of crud all round), removed and bunged swirl flaps with proper bungs, did an oil change and replaced oil breather.

    I also previously changed the fuel filter thinking at may be struggling for fuel.

    I did not clean the intercooler when I changed the turbo.

    My car should be running like a dream now it can breath well...but it isn't! I'm thinking maybe it is an electronic problem.

    Any suggestions would be most welcome!
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    Bimmer Fan
    Car Details
    Suddy's Car Details
    Model of Car:
    530d sport
    Year of Manufacture:
    2005
    Transmission Type:
    Auto
    Car Body Type:
    Saloon

    Join Date
    Sep 2013
    Location
    Wigan
    Posts
    19
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I've got a similar problem my next step is changing the exhaust back pressure sensor, mine was after changing the turbo aswel.
     
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts