Ews interface error, changing code incorrect, key not working 2005 E46 M3

Notices
 

Thread: Ews interface error, changing code incorrect, key not working 2005 E46 M3

Reply to Thread
Results 1 to 3 of 3
  1. Ews interface error, changing code incorrect, key not working 2005 E46 M3 
    #1
    Bimmer Fan
    Car Details
    Jahaddow's Car Details
    Model of Car:
    M3 CS
    Year of Manufacture:
    2005
    Transmission Type:
    SMG
    Car Body Type:
    Coupe

    Join Date
    Apr 2013
    Location
    Essex, UK
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hi, I have a M3 E46 2005 with two keys. I had just installed inpa the other day on my laptop and plugged in for some diagnostics, at this point both keys would start the car.

    Now something has happened during the last few days that has caused one of the keys, (the one I had in the ignition while using the software) to stop the car from starting. The second key still works..

    Inpa tells me a stored error code 66 ews-interface error
    Under the ews section it tells me that key no 1 is not valid because of incorrect changing code

    Very similar to the problem this guy is having E39 Key Activate using SSS progman / INPA or EWS Adjust HELP!

    When I try to to do an ews resync in inpa it gives me a script error

    Also might have something to do with it, I think the battery got very low the other day while I was plugged in, another forum said that the changing code can unsync if the key is left in and the battery goes flat.

    No idea what to do next..
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    Bimmer Fan
    Car Details
    abhardwaj1990's Car Details
    Model of Car:
    330d Sport
    Year of Manufacture:
    2001
    Transmission Type:
    Automatic
    Car Body Type:
    Saloon

    Join Date
    Nov 2012
    Location
    Nottingham
    Posts
    12
    Thanks
    0
    Thanked 1 Time in 1 Post
    I'm having pretty much the exact the same problem, but only have the one key.... My posts is here:

    HELP!! - Need someone that's good with electrics and/or BMW's in general!

    Pretty sure the error codes we got are similar if not the same.
    My battery had died (dead alternator I think), jumped fine 2-3 times on Saturday night to get me home, but died again with the keys in ignition, took the battery out to recharge...back in and got this :(


    Have you tried another battery while trying to re-sync? That's what I've been suggested, bought a new battery today to try it out...
     
     

  4.  
    #3
    Bimmer Fan
    Car Details
    Jahaddow's Car Details
    Model of Car:
    M3 CS
    Year of Manufacture:
    2005
    Transmission Type:
    SMG
    Car Body Type:
    Coupe

    Join Date
    Apr 2013
    Location
    Essex, UK
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I haven't tried a new battery but the one I've got is fine, putting out a good voltage 13.5. It's a script error I get when I try to resync, software related. Not sure if it is even possible to resync the rolling code of a key to the ews..?
     
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts