E92 Fault code P310E

Notices
 

Thread: E92 Fault code P310E

Reply to Thread
Results 1 to 8 of 8
  1. E92 Fault code P310E 
    #1
    Bimmer Fan
    Car Details
    paulsdunford's Car Details
    Model of Car:
    320i
    Year of Manufacture:
    2007
    Transmission Type:
    Manual
    Car Body Type:
    Coupe

    Join Date
    Oct 2010
    Location
    London
    Posts
    7
    Thanks
    1
    Thanked 0 Times in 0 Posts
    I got an engine warning lamp up yesterday - solid yellow. It then displayed the 'half engine' lamp briefly while it went into limp mode, and then that cleared and it has been driving OK since. The solid yellow engine lamp stayed on though.

    This morning I ran a diagnostic check and got the stored fault code P310E. I have cleared the stored fault code, and it has not returned having let the engine run for about ten minutes.

    Can anyone elighten me on what P310E means (my diagnostic kit simply says it is manufacturer specific). Any more advice to go along with the meaning of the fault code would be appreciated.

    The car is about 6 weeks out of warranty. Typical!

    Thanks

    Paul
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    Bimmer Fan
    Join Date
    Jul 2008
    Location
    Middlesex
    Posts
    11
    Thanks
    1,817
    Thanked 7,115 Times in 5,338 Posts
    Do you know what the CC-ID code is? Go to the Check Control message and press and hold the stalk button for a few seconds. Enda will be along shortly with his list of codes
     
     

  4.  
    #3
    Bimmer Fan
    Car Details
    paulsdunford's Car Details
    Model of Car:
    320i
    Year of Manufacture:
    2007
    Transmission Type:
    Manual
    Car Body Type:
    Coupe

    Join Date
    Oct 2010
    Location
    London
    Posts
    7
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Off to do it right now.

    Thanks - will report back shortly...

    Paul
     
     

  5. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  6.  
    #4
    Bimmer Fan
    Car Details
    paulsdunford's Car Details
    Model of Car:
    320i
    Year of Manufacture:
    2007
    Transmission Type:
    Manual
    Car Body Type:
    Coupe

    Join Date
    Oct 2010
    Location
    London
    Posts
    7
    Thanks
    1
    Thanked 0 Times in 0 Posts
    I'm assuming the BC stalk is the one with the mileage/mpg computer button on it, which is also the indicator stalk?

    After the button is held a couple of seconds I get two arrows displayed, but no words saying 'check control'. Flicking the stalk up and down brings up no codes and no further messages.

    Not sure if this means there is no problem now, or just that I'm doing something dossy!

    Thanks

    Paul
     
     

  7.  
    #5
    Bimmer Fan
    Car Details
    paulsdunford's Car Details
    Model of Car:
    320i
    Year of Manufacture:
    2007
    Transmission Type:
    Manual
    Car Body Type:
    Coupe

    Join Date
    Oct 2010
    Location
    London
    Posts
    7
    Thanks
    1
    Thanked 0 Times in 0 Posts
    OK - ignore the previous message. I got a bit more sense about me and did the check again. Must admit I am so used to manaufacturers hiding messages I didn't even bother to read the manual before. Lesson learned....

    I got to the 'check' message (didn't say 'check control') and then pressed the button on the end of the stalk. Got the 'check OK' message so I am now assuming there is nothing to report, and that when I cleared the code ealier with the diagnostic tool, it cleared any stored message in the check control too.

    I guess it is now a matter of just driving to see if I have a re-occurence.

    I'm now assuming I did the above check correctly and that there's nothing else I can do excpet wait to see if the problem comes back?

    Paul
     
     

  8.  
    #6
    BMW Guru
    Car Details
    TheEnd's Car Details
    Model of Car:
    540
    Year of Manufacture:
    1998
    Transmission Type:
    Auto
    Car Body Type:
    Saloon
    TheEnd's Avatar
    Join Date
    Jun 2010
    Location
    Birmingham
    Posts
    8,981
    Thanks
    478
    Thanked 2,990 Times in 2,440 Posts
    http://www.endtuning.com/ccidcodes.html

    There is some info on getting check control codes to see if you were into the correct section.

    P310E (or even just 310E) doesn't show up on any lists i have
     
     

  9.  
    #7
    Bimmer Fan
    Car Details
    paulsdunford's Car Details
    Model of Car:
    320i
    Year of Manufacture:
    2007
    Transmission Type:
    Manual
    Car Body Type:
    Coupe

    Join Date
    Oct 2010
    Location
    London
    Posts
    7
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Thank you for taking the time to check and help.

    I'm confident I did the check properly now, and the fact that it says 'Check OK' is enough to convince me that any stored codes are cleared, and having done the check both with and without the engine running, the fault isn't a constant one. Hopefully it is a one-off but we'll see....

    Paul
     
     

  10.  
    #8
    BMW Guru
    Car Details
    TheEnd's Car Details
    Model of Car:
    540
    Year of Manufacture:
    1998
    Transmission Type:
    Auto
    Car Body Type:
    Saloon
    TheEnd's Avatar
    Join Date
    Jun 2010
    Location
    Birmingham
    Posts
    8,981
    Thanks
    478
    Thanked 2,990 Times in 2,440 Posts
    Yep, if you got check OK, then there was nothing it felt it needed to say.
     
     

  11. The Following User Says Thank You to TheEnd For This Useful Post:

    paulsdunford (13-10-2010)

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts