E39 Key Activate using SSS progman / INPA or EWS Adjust HELP!

Notices
 

Thread: E39 Key Activate using SSS progman / INPA or EWS Adjust HELP!

Reply to Thread
Page 1 of 3 123 LastLast
Results 1 to 10 of 21
  1. E39 Key Activate using SSS progman / INPA or EWS Adjust HELP! 
    #1
    Bimmer Fan
    Car Details
    steve1564's Car Details
    Model of Car:
    520i SE
    Year of Manufacture:
    2000
    Transmission Type:
    Manual
    Car Body Type:
    Touring
    steve1564's Avatar
    Join Date
    May 2012
    Location
    Clevedon Somerset
    Posts
    9
    Thanks
    8
    Thanked 1 Time in 1 Post
    ..... I'm getting thin enough on top without pulling any more hair out over this !


    I have an e39 (2000 my) - i have 2 keys - One is in pieces & will start the car if you hold the transponer near the antenna ring...

    The other is complete but wont start the car... It's identified as key 0 on INPA or Progman and the stated reason is "Changing Code" (all the other functions are OK)- do i simply need to re-sync it ? - if so......

    Question - how do you do a ews re-sync? (i tried EWS Adjustment) - It runs then throws up a trouble code & states it was'nt done

    - I did the changes.iso thing - when i start the prog it tells me the batt v is 14.0v - go anywhere else & it reverts back to 12.4 - i know this will stop you programming but the EWS adjustment continues past that stage..

    Am i heading in the right direction or do i need to be doing somthing else?

    when you do a key list it states leys 0-3 as active & used the only difference is 1-3 start as 04 00 00 00 00 00 00 and key 0 is 08 00 00 00 00 00 00

    Guess i need a step by step guide - I'm starting to glaze over with this so i may have missed somthing stupid...
    If i try an ews re-sync in INPA it throws an "scripting error code"

    Thanks in advance - Steve
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    BMW Guru
    Car Details
    TheEnd's Car Details
    Model of Car:
    540
    Year of Manufacture:
    1998
    Transmission Type:
    Auto
    Car Body Type:
    Saloon
    TheEnd's Avatar
    Join Date
    Jun 2010
    Location
    Birmingham
    Posts
    8,979
    Thanks
    478
    Thanked 2,990 Times in 2,440 Posts
    The EWS adjustment is EWS>DME, and not key>EWS.

    I'm not sure if you can reset a key easily, or if it even should become unsynchronised.
     
     

  4. The Following User Says Thank You to TheEnd For This Useful Post:

    steve1564 (18-05-2012)

  5.  
    #3
    Bimmer Fan
    Car Details
    steve1564's Car Details
    Model of Car:
    520i SE
    Year of Manufacture:
    2000
    Transmission Type:
    Manual
    Car Body Type:
    Touring
    steve1564's Avatar
    Join Date
    May 2012
    Location
    Clevedon Somerset
    Posts
    9
    Thanks
    8
    Thanked 1 Time in 1 Post
    Thanks ....

    is that in progman or INPA ?

    Im getting ISN invalid in inpa
     
     

  6. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  7.  
    #4
    BMW Guru
    Car Details
    TheEnd's Car Details
    Model of Car:
    540
    Year of Manufacture:
    1998
    Transmission Type:
    Auto
    Car Body Type:
    Saloon
    TheEnd's Avatar
    Join Date
    Jun 2010
    Location
    Birmingham
    Posts
    8,979
    Thanks
    478
    Thanked 2,990 Times in 2,440 Posts
    Have you even had both keys working?
    The ISN is in the EWS box and the ECU, and shouldn't be different between keys.
     
     

  8. The Following User Says Thank You to TheEnd For This Useful Post:

    steve1564 (18-05-2012)

  9.  
    #5
    Bimmer Fan
    Car Details
    steve1564's Car Details
    Model of Car:
    520i SE
    Year of Manufacture:
    2000
    Transmission Type:
    Manual
    Car Body Type:
    Touring
    steve1564's Avatar
    Join Date
    May 2012
    Location
    Clevedon Somerset
    Posts
    9
    Thanks
    8
    Thanked 1 Time in 1 Post
    Thanks For the quick reply's.....

    ... Thats the thing,

    Bought the car with the fault, it came with the 2 keys.... it could be that 1 key never worked but it does show up as active & used in INPA

    it reads & has the correct ID - the only item that fails is the "changing code" (it's id'd as key 0)

    The other key works & is id'd as key 1 - but has a weak tranponder and you have to hold the PCB (like i said it's in bits) up against the antenna

    Both keys show up as active & used....

    My (simple) understanding is that if the DME & EWS are chatting (which they obviously are cos the car starts with key 1) then the issue will be with the key or what the ews is expecting it to say after it says hello! - at the moment key 1 is saying "How do you do - would you like to go for a nice drive? to which the EWS says "Okey dokey skip"

    Whereas key 0 is saying "Oi... you looking at my bird"... and the EWS says "Right.... You... Outside NOW ! -


    ... Wierd !

    ... I'm sure its somthing simple - but i'm batteling with the 12.4v issue at the moment & looks like i'll have to reload sss anyway, - I'm new to all this and its been a learning curve... do you think i'd be better off with DIS V44 ? as it's all under one roof or shall i stick with V57 & SSS ?

    Steve
     
     

  10.  
    #6
    BMW Guru
    Car Details
    TheEnd's Car Details
    Model of Car:
    540
    Year of Manufacture:
    1998
    Transmission Type:
    Auto
    Car Body Type:
    Saloon
    TheEnd's Avatar
    Join Date
    Jun 2010
    Location
    Birmingham
    Posts
    8,979
    Thanks
    478
    Thanked 2,990 Times in 2,440 Posts
    It is looking like some of the rolling keycodes are unsynced which a) I thought was impossible, and b) I don't think it has any easy resync methods.

    DIS 44 is easier to work with, and will cover everything, and it has guided fault finding which will run you through what to do, and it has all of the progman programming features built in (but an earlier version)

    Try this iso instead of the "changes" version, it's the one I use without any problems. There is a changes v2 that might also be similar.
    It's a version I did myself, based on one called full start, but it'll also add MINI into progman too
    Attached Files
     
     

  11. The Following User Says Thank You to TheEnd For This Useful Post:

    steve1564 (18-05-2012)

  12.  
    #7
    FAL
    FAL is offline
    BMW Fanatic
    Car Details
    FAL's Car Details
    Model of Car:
    R53
    Year of Manufacture:
    2006
    Transmission Type:
    Manual
    Car Body Type:
    Hatchback

    Join Date
    Jun 2010
    Location
    Warwickshire
    Posts
    89
    Thanks
    62
    Thanked 41 Times in 35 Posts
    Have you tried the EWS_KEYS.IPO key test in INPA? Should be located in C:\EC-APPS\INPA\SGDAT - you can double-click on it and run it direct.
     
     

  13. The Following User Says Thank You to FAL For This Useful Post:

    steve1564 (18-05-2012)

  14.  
    #8
    Bimmer Fan
    Car Details
    steve1564's Car Details
    Model of Car:
    520i SE
    Year of Manufacture:
    2000
    Transmission Type:
    Manual
    Car Body Type:
    Touring
    steve1564's Avatar
    Join Date
    May 2012
    Location
    Clevedon Somerset
    Posts
    9
    Thanks
    8
    Thanked 1 Time in 1 Post
    What a hero... Thanks

    Will that work with v44 (assuming you still get the undervolt issue) ?



    It does look like the rolling code for key 0 has unsynced....

    I'm going to load up V44 (if i can find a good image) & try that -

    with v57 & sss i have 2 VM's running and it gets a bit confusing for my tiny brain!


    On another note have you had any dealings with the EWS bypass thingys they sell on ebay? -

    BMW EWS EWS 2 EWS 3.2 Immo Emulator BMW Key Programmer Worldwide Free Shipping | eBay


    Thought that may be a way round it - then i can just get blanks cut at Timpsons ?

    Thanks Again (beer om me if we ever meet up !)

    Steve
     
     

  15.  
    #9
    Bimmer Fan
    Car Details
    steve1564's Car Details
    Model of Car:
    520i SE
    Year of Manufacture:
    2000
    Transmission Type:
    Manual
    Car Body Type:
    Touring
    steve1564's Avatar
    Join Date
    May 2012
    Location
    Clevedon Somerset
    Posts
    9
    Thanks
    8
    Thanked 1 Time in 1 Post
    Thanks FAL

    No... Like i said it's all a bit new to me (the volvo is so much easier !) -

    I'll try it tomorrow & post back... In the meantime any idea where i can find dis v44 ? -


    Cheers - Steve
     
     

  16.  
    #10
    BMW Guru
    Car Details
    TheEnd's Car Details
    Model of Car:
    540
    Year of Manufacture:
    1998
    Transmission Type:
    Auto
    Car Body Type:
    Saloon
    TheEnd's Avatar
    Join Date
    Jun 2010
    Location
    Birmingham
    Posts
    8,979
    Thanks
    478
    Thanked 2,990 Times in 2,440 Posts
    I don't think that EWS emulator will work, it doesn't work on MS42 or MS43 ecus.
     
     

Page 1 of 3 123 LastLast
Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts