E36 Instrument cluster (KOMBI) diagnostic

Notices
 

Thread: E36 Instrument cluster (KOMBI) diagnostic

Reply to Thread
Page 1 of 3 123 LastLast
Results 1 to 10 of 21
  1. E36 Instrument cluster (KOMBI) diagnostic 
    #1
    Bimmer Fan
    Car Details
    Qwazas's Car Details
    Model of Car:
    328i
    Year of Manufacture:
    99
    Transmission Type:
    Manual
    Car Body Type:
    Touring

    Join Date
    May 2011
    Location
    PL
    Posts
    10
    Thanks
    4
    Thanked 3 Times in 3 Posts
    Hello,

    I try to connect with instrument cluster (KOMBI) using INPA.The car is E36 316 1997 COMPACT.
    I have an ADS interface but INPA shows an error "IFH-0009: NO RESPONSE FROM CONTROL UNIT"
    EDIABAS settings are correct because rest of modules are available excepth that one.

    Does ony one have any idea what is wrong that connection can't be established?
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    BMW Guru
    Car Details
    joylove's Car Details
    Model of Car:
    328
    Year of Manufacture:
    1998
    Transmission Type:
    Manual
    Car Body Type:
    cabrio

    Join Date
    Sep 2010
    Location
    UK
    Posts
    1,500
    Thanks
    108
    Thanked 467 Times in 367 Posts
    Are you sure all modules are available, including the ABS, ASC and ZKE?

    If so there should be no technical reason why the module doesn't respond. Are you trying to solve a particular issue? The cluster does have test modes that can be accessed without INPA.
     
     

  4.  
    #3
    Super Moderator
    Car Details
    dailydoggy's Car Details
    Model of Car:
    330i
    Year of Manufacture:
    2001
    Transmission Type:
    manual
    Car Body Type:
    saloon
    dailydoggy's Avatar
    Join Date
    Sep 2009
    Location
    UK
    Posts
    12,412
    Thanks
    1,817
    Thanked 5,256 Times in 4,088 Posts
    wot do you call an ADS interface?
    330i sport a big chunk of berlin...

     
     

  5. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  6.  
    #4
    Bimmer Fan
    Car Details
    Qwazas's Car Details
    Model of Car:
    328i
    Year of Manufacture:
    99
    Transmission Type:
    Manual
    Car Body Type:
    Touring

    Join Date
    May 2011
    Location
    PL
    Posts
    10
    Thanks
    4
    Thanked 3 Times in 3 Posts
    Quote Originally Posted by joylove View Post
    Are you sure all modules are available, including the ABS, ASC and ZKE?

    If so there should be no technical reason why the module doesn't respond. Are you trying to solve a particular issue? The cluster does have test modes that can be accessed without INPA.
    Yes.All these modules are available.Just only KOMBI doesn't respond.The starnge thing is that other person who has similiar car is struggling with the same problem.
    What do you mean "The cluster does have test modes that can be accessed without INPA"?
     
     

  7.  
    #5
    Bimmer Fan
    Car Details
    Qwazas's Car Details
    Model of Car:
    328i
    Year of Manufacture:
    99
    Transmission Type:
    Manual
    Car Body Type:
    Touring

    Join Date
    May 2011
    Location
    PL
    Posts
    10
    Thanks
    4
    Thanked 3 Times in 3 Posts
    Quote Originally Posted by dailydoggy View Post
    wot do you call an ADS interface?
    My ADS interface is on Rs-232 port and RxD line is available.
     
     

  8.  
    #6
    BMW Guru
    Car Details
    joylove's Car Details
    Model of Car:
    328
    Year of Manufacture:
    1998
    Transmission Type:
    Manual
    Car Body Type:
    cabrio

    Join Date
    Sep 2010
    Location
    UK
    Posts
    1,500
    Thanks
    108
    Thanked 467 Times in 367 Posts
    Quote Originally Posted by Qwazas View Post
    Yes.All these modules are available.Just only KOMBI doesn't respond.The starnge thing is that other person who has similiar car is struggling with the same problem.
    What do you mean "The cluster does have test modes that can be accessed without INPA"?
    There is a testmode that will light all the lamps and sweep all the gauges. There are guides on Google, I think you hold a button down while turning on the ignition or something. What problem are you trying to resolve?
     
     

  9.  
    #7
    Bimmer Fan
    Car Details
    Qwazas's Car Details
    Model of Car:
    328i
    Year of Manufacture:
    99
    Transmission Type:
    Manual
    Car Body Type:
    Touring

    Join Date
    May 2011
    Location
    PL
    Posts
    10
    Thanks
    4
    Thanked 3 Times in 3 Posts
    That test of instrument cluster can be done as you said but I'm trying to figure out why INPA and DIS cannot connect with instrument cluster in this car.I add that the same interface is able to connect with instrument cluster in other E36 cars.
    So I would know whether other owners of E36 316 97 COMPACT have similiar problem like mine.
     
     

  10.  
    #8
    Administrator
    Car Details
    Ian S's Car Details
    Model of Car:
    M3 Evo, E60 530D, 911 C4S, Yaris T Sport
    Year of Manufacture:
    1996
    Transmission Type:
    Manual
    Car Body Type:
    Loon
    Ian S's Avatar
    Join Date
    Jun 2008
    Location
    Bristol
    Posts
    3,958
    Thanks
    2,146
    Thanked 2,253 Times in 1,723 Posts
    You've used your setup on another E36, or someone else with the same interface can perform the test on E36's?

    I ask because it really does sound like an ADS config issue. If I use my obd2 interface on my E36 I can connect to most things apart from the IC. Sorry if you've already done this, but it's worth checking that you have run adssetup and configured the obd.ini to use ADS? Just checking that you're not running a switchable interface in OBD mode.

    Ian
     
     

  11.  
    #9
    Bimmer Fan
    Car Details
    Qwazas's Car Details
    Model of Car:
    328i
    Year of Manufacture:
    99
    Transmission Type:
    Manual
    Car Body Type:
    Touring

    Join Date
    May 2011
    Location
    PL
    Posts
    10
    Thanks
    4
    Thanked 3 Times in 3 Posts
    Test performed my collegue with my ADS interface using his own computer.EDIABAS.INI is set up for ADS.The same is in OBD.ini.So it seems everything is correct there.Except that adssetup was run at the berginning of program's installation.
    That interface can connect to instrument clusters in others E36 cars but not in this one.
    Similiar case has other colleague with connection to his instrument cluster in E36 316 COMPACT using ADS hardware (not mine but it is working properly as well)
    Recently he has tried to connect directly using Tool32 but result was the same:no connection.
    Anyway it might be an electrical problem but exact the same in both cars? Of course it possible.
     
     

  12.  
    #10
    Dr of BMW
    Car Details
    mistreku's Car Details
    Model of Car:
    325i
    Year of Manufacture:
    1993
    Transmission Type:
    Manual
    Car Body Type:
    Coupe
    mistreku's Avatar
    Join Date
    Oct 2009
    Location
    Luton, Beds
    Posts
    1,250
    Thanks
    716
    Thanked 569 Times in 390 Posts
    OP, could you please attach your ADS config files here? I'm having some issues with mine as well. However, mine are more severe. It sort of works, but it doesn't. It notices when battery and ignition are on, I can connect to ABS module, Central locking, Kombi, but can't connect to the DME - the most important of all. I first get a "inpa data transmission control unit disturbed" error, and after closing it, another one saying that the DME or DME file wasn't found, can't remember exactly.

    I have a hunch it's related to the config files, but not sure. Or perhaps COM settings? Any suggestions are more than welcome! Thanks
    There are only two products required to make the universe work properly: Duct tape and WD40. 


    If it moves (and it shouldn't): duct tape. 
If it doesn’t move (and it should): WD40.

    Everything else is just stuff.
     
     

Page 1 of 3 123 LastLast
Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts