BMW and INPA success E39/E46 onwards - Page 4

Notices
 

Thread: BMW and INPA success E39/E46 onwards

Reply to Thread
Page 4 of 7 FirstFirst 1234567 LastLast
Results 31 to 40 of 65
  1.  
    #31
    FAL
    FAL is offline
    BMW Fanatic
    Car Details
    FAL's Car Details
    Model of Car:
    R53
    Year of Manufacture:
    2006
    Transmission Type:
    Manual
    Car Body Type:
    Hatchback

    Join Date
    Jun 2010
    Location
    Warwickshire
    Posts
    89
    Thanks
    62
    Thanked 41 Times in 35 Posts
    Quote Originally Posted by sergeantash View Post
    ...but I am yet to test it actually connected to the car - however I notice that there isn't an E46 option on the front INPA page?
    Don't worry about the lack of an E46 option, that's an easy-fix. For now, just make sure that your interface is working and showing both the battery and ignition status on the INPA start screen.
    Quote Originally Posted by sergeantash View Post
    Should I not have upgraded INPA to the latest version?
    No, it's not impotant for an E46, as no new diagnostic, coding or module flash files have been released, for quite a few years now. The newer versions of Ediabas and INPA, are only really important if you want to start working with Ethernet, ICOM, Flexray, etc. interfaces and the latest F-series cars. Post a screen-shot of what you are getting on your INPA start screen and from that, i can work out and configure the background, selection and script files, for what you want/need.
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #32
    BMW Crazed
    Car Details
    sergeantash's Car Details
    Model of Car:
    E46 M3
    Year of Manufacture:
    2004 (04)
    Transmission Type:
    SMG2
    Car Body Type:
    Coupe

    Join Date
    Jul 2010
    Location
    South West
    Posts
    102
    Thanks
    6
    Thanked 41 Times in 6 Posts
    Hey Fal - thanks for your help here! Right, with the interface disconnected from the car, I get this screen:

    inpa_start.jpg

    The top left two blobs flash randomly whilst disconnected too.

    I'll head out now and try connecting it to the car
     
     

  4.  
    #33
    BMW Crazed
    Car Details
    sergeantash's Car Details
    Model of Car:
    E46 M3
    Year of Manufacture:
    2004 (04)
    Transmission Type:
    SMG2
    Car Body Type:
    Coupe

    Join Date
    Jul 2010
    Location
    South West
    Posts
    102
    Thanks
    6
    Thanked 41 Times in 6 Posts
    Right, just been in the car - the home page of INPA stays the same regardless, the ignition and battery blobs always remain solid black - the two little blobs on the far left always flicker constantly but that happens whether connected to the car or not. I tried different states of ignition, i.e. key positions 1/2 and running yet the home page of INPA didn't change.

    I then did some tests, using the E39 options, I tried some that I assumed might be fairly generic, 'Radio' for instance, and I was indeed able to turn the radio volume up and down using INPA, I could also read some codes from the Steering Wheel position, also engine revs and petrol tank contents.

    So, looks like it is talking but perhaps not fully? Could you guide me on getting the E46 specific options to appear - I'm anxious to diagnose whether I have a faulty Xenon igniter or ballast on the passenger side, i'm hoping that there'll be a test in there somewhere to determine that?

    Also, with INPA, is there a way to show all faults in one go rather than paging through pages of INPA individual tests?

    Thanks for your help so far, and Happy New Year

    Screenshots below:

    inpa_CAN.jpg

    inpa_coding.jpg

    inpa_dashboard.jpg
     
     

  5.  
    #34
    FAL
    FAL is offline
    BMW Fanatic
    Car Details
    FAL's Car Details
    Model of Car:
    R53
    Year of Manufacture:
    2006
    Transmission Type:
    Manual
    Car Body Type:
    Hatchback

    Join Date
    Jun 2010
    Location
    Warwickshire
    Posts
    89
    Thanks
    62
    Thanked 41 Times in 35 Posts
    Quote Originally Posted by sergeantash View Post
    Could you guide me on getting the E46 specific options to appear - I'm anxious to diagnose whether I have a faulty Xenon igniter or ballast on the passenger side, i'm hoping that there'll be a test in there somewhere to determine that?
    Yes, there is. You appear to have an INPA version from circa-2006/2007, so if you have a look in Old Models on the main screen, you should find the E46 chassis. In the Body section, you should find Xenon Left and Xenon Right.
    Quote Originally Posted by sergeantash View Post
    Also, with INPA, is there a way to show all faults in one go rather than paging through pages of INPA individual tests?
    Yes, there is. In the main E46 section, you should find Functional Jobs... ...however, this will only give you the name of the module with the fault, the number of faults within the memory of that module and a short engineering fault code... ...for a more in-depth explanation of the fault, you will need to examine the error memory within the module itself, using the aforementioned Xenon script files.
     
     

  6.  
    #35
    BMW Crazed
    Car Details
    sergeantash's Car Details
    Model of Car:
    E46 M3
    Year of Manufacture:
    2004 (04)
    Transmission Type:
    SMG2
    Car Body Type:
    Coupe

    Join Date
    Jul 2010
    Location
    South West
    Posts
    102
    Thanks
    6
    Thanked 41 Times in 6 Posts
    Quote Originally Posted by FAL View Post
    Yes, there is. You appear to have an INPA version from circa-2006/2007, so if you have a look in Old Models on the main screen, you should find the E46 chassis. In the Body section, you should find Xenon Left and Xenon Right.
    Yes, there is. In the main E46 section, you should find Functional Jobs... ...however, this will only give you the name of the module with the fault, the number of faults within the memory of that module and a short engineering fault code... ...for a more in-depth explanation of the fault, you will need to examine the error memory within the module itself, using the aforementioned Xenon script files.
    Oddly the E46 isn't in there, I had already checked - E36 and E39 are but nothing relating to my model - I attempted to install INPA some months ago and found the same issue? Any ideas? Is there anything that I can manually edit to get E46 on the front screen as a direct F key?

    Alternatively, is there an app better than INPA for reading codes and setting some nice optional extras?
     
     

  7.  
    #36
    FAL
    FAL is offline
    BMW Fanatic
    Car Details
    FAL's Car Details
    Model of Car:
    R53
    Year of Manufacture:
    2006
    Transmission Type:
    Manual
    Car Body Type:
    Hatchback

    Join Date
    Jun 2010
    Location
    Warwickshire
    Posts
    89
    Thanks
    62
    Thanked 41 Times in 35 Posts
    Quote Originally Posted by sergeantash View Post
    oddly the e46 isn't in there, i had already checked - e36 and e39 are but nothing relating to my model - i attempted to install inpa some months ago and found the same issue? Any ideas? Is there anything that i can manually edit to get e46 on the front screen as a direct f key?
    Open up INPA's config' file (C:\EC-APPS\INPA\CFGDAT) with any text editor and add this:



    ...then un-zip and add this config...

    https://www.rapidshare.com/files/2729689918/E46.zip

    ...to the config' folder as well (C:\EC-APPS\INPA\CFGDAT).

    Quote Originally Posted by sergeantash View Post
    Alternatively, is there an app better than inpa for reading codes and setting some nice optional extras?
    I've got to go to a New Years Eve party now, but i'll answer that one with some deatails, tomorrow...
     
     

  8. The Following User Says Thank You to FAL For This Useful Post:

    unclebigbad1 (05-01-2012)

  9.  
    #37
    BMW Crazed
    Car Details
    sergeantash's Car Details
    Model of Car:
    E46 M3
    Year of Manufacture:
    2004 (04)
    Transmission Type:
    SMG2
    Car Body Type:
    Coupe

    Join Date
    Jul 2010
    Location
    South West
    Posts
    102
    Thanks
    6
    Thanked 41 Times in 6 Posts
    Quote Originally Posted by FAL View Post
    Open up INPA's config' file (C:\EC-APPS\INPA\CFGDAT) with any text editor and add this:

    Ahhhh nice one, I opened this .ini file and found the following commented out and so used it for my E46 entry:

    //F3 = F10
    //F3_Text = F10
    //F3_ARCHIV = SGBD_F10

    I changed it, as per your instructions, to:

    F3 = E46
    F3_Text = E46
    F3_ARCHIV = SGBD_E46

    Quote Originally Posted by FAL View Post
    ...then un-zip and add this config...

    https://www.rapidshare.com/files/2729689918/E46.zip

    ...to the config' folder as well (C:\EC-APPS\INPA\CFGDAT).
    I looked in this folder first and found an E46 configuration file that already existed, I fired up INPA and the full E46 feature set did indeed appear successfully - however, I downloaded the config file that you linked to and found that it was slightly larger in filesize than my existing E46.ENG file, also had a newer date and so I assume that it has more supported tests within it? The only real differences that I could see were that some tests had now been separated by a carriage return, but also that the tests were all uppercase - I have attached the two files as .txt files so that you can take a look and hopefully help me determine which is the best

    I also notice that the newer one includes the 'Functional Tests' option, however when selecting it there aren't any listed tests for the E46?

    Quote Originally Posted by FAL View Post
    I've got to go to a New Years Eve party now, but i'll answer that one with some deatails, tomorrow...
    Haha, hope that you had a good evening! Now that I have INPA running, I'm interested in other apps that I can use without having to use a VM setup. It is still however rather odd that the 'Ignition' and 'Battery' indicators on the frontpage of INPA remain permanently on whether the ignition is on or not? The only time that the indicators state 'Off' is when I unplug my USB interface cable.

    Thanks also for your help, its great to get some solid information regarding INPA, there are so many confusing threads throughout all BMW forums, nothing very clear and reliable. I think that you should put together a guide!
    Attached Files
     
     

  10. The Following User Says Thank You to sergeantash For This Useful Post:

    unclebigbad1 (05-01-2012)

  11.  
    #38
    FAL
    FAL is offline
    BMW Fanatic
    Car Details
    FAL's Car Details
    Model of Car:
    R53
    Year of Manufacture:
    2006
    Transmission Type:
    Manual
    Car Body Type:
    Hatchback

    Join Date
    Jun 2010
    Location
    Warwickshire
    Posts
    89
    Thanks
    62
    Thanked 41 Times in 35 Posts
    Quote Originally Posted by sergeantash View Post
    I looked in this folder first and found an E46 configuration file that already existed, I fired up INPA and the full E46 feature set did indeed appear successfully - however, I downloaded the config file that you linked to and found that it was slightly larger in file size than my existing E46.ENG file, also had a newer date and so I assume that it has more supported tests within it?
    Good news, glad to hear it. It looks like you have the latest (and the last) E46.ENG file already, so no problems there.
    Quote Originally Posted by sergeantash View Post
    It is still however rather odd that the 'Ignition' and 'Battery' indicators on the front page of INPA remain permanently on whether the ignition is on or not? The only time that the indicators state 'Off' is when I unplug my USB interface cable.
    It’s not a problem i’ve come across before, but it sounds like an interface hardware issue. What are your settings, within your Ediabas.ini config'? (C:\Ediabas\Bin) ...and what interface are you using?
    Quote Originally Posted by sergeantash View Post
    Thanks also for your help, it’s great to get some solid information regarding INPA, there are so many confusing threads throughout all BMW forums, nothing very clear and reliable. I think that you should put together a guide!
    I'm happy to write guides (free time permiting), if members let me know what subjects they want me to cover?
    Quote Originally Posted by sergeantash View Post
    Alternatively, is there an app better than INPA for reading codes and setting some nice optional extras?
    There’s nothing “better” than INPA for diagnostics as such, as it is BMW's own engineering tool and is still in use today. It’s also worth noting that Tool Set 32 (C:\Ediabas\Bin) is a very powerful and valuable addition! The only other tools that come close (in my opinion), are ISTA-D, BMW Commander and BMW Explorer, but they are very expensive. For setting additional optional extras, Tool Set 32 and NCS are what you will need to become comfortable using…
     
     

  12. The Following User Says Thank You to FAL For This Useful Post:

    sergeantash (01-01-2012)

  13.  
    #39
    BMW Crazed
    Car Details
    sergeantash's Car Details
    Model of Car:
    E46 M3
    Year of Manufacture:
    2004 (04)
    Transmission Type:
    SMG2
    Car Body Type:
    Coupe

    Join Date
    Jul 2010
    Location
    South West
    Posts
    102
    Thanks
    6
    Thanked 41 Times in 6 Posts
    Quote Originally Posted by FAL View Post
    Good news, glad to hear it. It looks like you have the latest (and the last) E46.ENG file already, so no problems there.
    Cool - I do wonder if there are some hidden tests that aren't included within the file! Its a shame about the 'Functional tests' option as it would be great to see all errors immediately rather than having to run each

    Quote Originally Posted by FAL View Post
    It’s not a problem i’ve come across before, but it sounds like an interface hardware issue. What are your settings, within your Ediabas.ini config'?
    I'm using this interface: BMW Diagnostic Software Cable lead Ediabas Inpa DIS SSS | eBay - I have also attached my EDIABAS.ini to this reply as a TXT file - hopefully you'll be able to suss out if I have misconfigured something? File here: EDIABAS.txt

    Quote Originally Posted by FAL View Post
    I'm happy to write guides (free time permiting), if members let me know what subjects they want me to cover?
    After spending so long trying to get this to work, I had written some notes to help me if I ever needed to reinstall, I've just formatted it nicely and put it up as a thread, hopefully it'll prove useful to others trying to get this to work on Windows 7 - I've even put a credit at the end to thank you

    Guide: Installing INPA/EDIABAS on Windows 7 64bit

    Quote Originally Posted by FAL View Post
    For setting additional optional extras, Tool Set 32 and NCS are what you will need to become comfortable using…
    These look a little less GUI friendly - can you point me to any useful references on how to use these?

    Thanks again for all of your help! I can go and diagnose my Xenon issue finally!!!
     
     

  14.  
    #40
    BMW Crazed
    Car Details
    sergeantash's Car Details
    Model of Car:
    E46 M3
    Year of Manufacture:
    2004 (04)
    Transmission Type:
    SMG2
    Car Body Type:
    Coupe

    Join Date
    Jul 2010
    Location
    South West
    Posts
    102
    Thanks
    6
    Thanked 41 Times in 6 Posts
    Just been out to the car - all the tests work brilliantly, except for the Xenon test in INPA which fails to even open regardless of whether I select Left or Right :(

    Last edited by sergeantash; 02-01-2012 at 14:03.
     
     

Page 4 of 7 FirstFirst 1234567 LastLast

LinkBacks (?)

  1. 13-12-2012, 21:57
  2. 08-12-2012, 10:46
  3. 25-11-2012, 19:01
  4. 12-11-2012, 07:39
  5. 03-11-2012, 20:06
  6. 24-10-2012, 00:19
  7. 11-10-2012, 05:57
  8. 08-10-2012, 22:43
  9. 08-10-2012, 22:07
  10. 11-09-2012, 13:14
  11. 28-08-2012, 13:06
  12. 28-08-2012, 12:25
  13. 28-08-2012, 12:05
  14. 27-08-2012, 21:26
  15. 13-08-2012, 21:36
  16. 28-07-2012, 12:14
  17. 26-06-2012, 17:22
  18. 06-06-2012, 10:49
  19. 03-06-2012, 18:15
  20. 31-05-2012, 15:51
  21. 13-05-2012, 06:51
  22. 09-05-2012, 03:36
  23. 04-05-2012, 21:40
  24. 27-04-2012, 23:35
  25. 26-04-2012, 00:04
  26. 25-04-2012, 14:32
  27. 19-04-2012, 19:37
  28. 17-04-2012, 00:01
  29. 13-04-2012, 08:13
  30. 26-03-2012, 14:28
  31. 22-03-2012, 17:00
  32. 22-03-2012, 03:24
  33. 13-03-2012, 18:34
  34. 07-03-2012, 01:37
  35. 04-03-2012, 16:59
  36. 04-03-2012, 09:26
  37. 28-02-2012, 06:04
  38. 27-02-2012, 23:35
  39. 13-02-2012, 21:10
  40. 11-02-2012, 17:13
  41. 10-02-2012, 03:11
  42. 01-02-2012, 17:52
  43. 18-01-2012, 16:01
  44. 08-01-2012, 03:25
  45. 04-01-2012, 01:54
  46. 02-01-2012, 19:04
  47. 25-12-2011, 14:06
  48. 24-12-2011, 23:07
  49. 24-12-2011, 17:55
  50. 22-12-2011, 01:40

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts