2003 E46 330D Sport - ABS warning lights on/reset(FIXED) - Page 2

Notices
 

Thread: 2003 E46 330D Sport - ABS warning lights on/reset(FIXED)

Reply to Thread
Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 26
  1.  
    #11
    Bimmer Fan
    Car Details
    neverracedorrallied's Car Details
    Model of Car:
    E46 330D Sport
    Year of Manufacture:
    2003
    Transmission Type:
    Manual
    Car Body Type:
    Saloon

    Join Date
    May 2009
    Location
    Berkshire
    Posts
    13
    Thanks
    2
    Thanked 0 Times in 0 Posts
    Yes, it is from GSF, do you thinkthat could be the problem?
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #12
    Bimmer Fan
    Car Details
    neverracedorrallied's Car Details
    Model of Car:
    E46 330D Sport
    Year of Manufacture:
    2003
    Transmission Type:
    Manual
    Car Body Type:
    Saloon

    Join Date
    May 2009
    Location
    Berkshire
    Posts
    13
    Thanks
    2
    Thanked 0 Times in 0 Posts
    So I fitted a NSR sensor supplied by GSF, is that not adviseable then?

    TIA
     
     

  4.  
    #13
    Bimmer Fan
    Join Date
    Jul 2008
    Location
    Middlesex
    Posts
    11
    Thanks
    1,817
    Thanked 7,115 Times in 5,338 Posts
    Sorry mate, never got back to you on this ....aftermarket sensors are prone to early failure, in some cases, they don't work at all.
     
     

  5.  
    #14
    Bimmer Fan
    Car Details
    neverracedorrallied's Car Details
    Model of Car:
    E46 330D Sport
    Year of Manufacture:
    2003
    Transmission Type:
    Manual
    Car Body Type:
    Saloon

    Join Date
    May 2009
    Location
    Berkshire
    Posts
    13
    Thanks
    2
    Thanked 0 Times in 0 Posts
    YES YOU ARE DEAD RIGHT! After TWO pattern part sensors were tried, I went to BMW, paid more than twice the price (£107 inc vat) and bingo, it worked first time; speedo, odo, thrashometer, abs, dsc all restored!

    Result, thanks very much :-)
     
     

  6.  
    #15
    BMW Guru
    Car Details
    Ronnie's Car Details
    Model of Car:
    See above
    Year of Manufacture:
    Never too old, never too new
    Transmission Type:
    Always manual
    Car Body Type:
    Usually 5 doors
    Ronnie's Avatar
    Join Date
    Dec 2007
    Location
    Bournemouth, Dorset.
    Posts
    20,394
    Thanks
    6,198
    Thanked 7,051 Times in 5,322 Posts
    Quote Originally Posted by neverracedorrallied View Post
    YES YOU ARE DEAD RIGHT! After TWO pattern part sensors were tried, I went to BMW, paid more than twice the price (£107 inc vat) and bingo, it worked first time; speedo, odo, thrashometer, abs, dsc all restored!

    Result, thanks very much :-)
    Good to hear you have fixed the problem and cheers for the update
     
     

  7. abs and speedo not working 
    #16
    Bimmer Fan
    Car Details
    BIGMILLWARD's Car Details
    Model of Car:
    525i sport
    Year of Manufacture:
    2000
    Transmission Type:
    manual
    Car Body Type:
    saloon

    Join Date
    Jun 2009
    Location
    GLASGOW
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Got the same thing with my 525i sport its driving me nuts done the abs sensor nsr solved the problem for about five mins. my speedo was working when it gets frosty lol since the weather has got better its not worked in weeks have to use a sat nav for a speedo. have been told to get the abs ecu rebuilt by a company called dcs i think £115 + the vat but its not guaranteed to work thats all and can't afford to take the chance right now. let me now how it goes.
     
     

  8.  
    #17
    Bimmer Fan
    Car Details
    neverracedorrallied's Car Details
    Model of Car:
    E46 330D Sport
    Year of Manufacture:
    2003
    Transmission Type:
    Manual
    Car Body Type:
    Saloon

    Join Date
    May 2009
    Location
    Berkshire
    Posts
    13
    Thanks
    2
    Thanked 0 Times in 0 Posts
    Did you use a genuine part? Mine seems to be ok now fingers crossed. It is a real pain without the speedo, odometer etc and it even seemed to have an effect on the external temperature gauge and fuel gauge, annoying. Have you had a diagnostic tool connected up to it yet?
     
     

  9.  
    #18
    Bimmer Fan
    Car Details
    BIGMILLWARD's Car Details
    Model of Car:
    525i sport
    Year of Manufacture:
    2000
    Transmission Type:
    manual
    Car Body Type:
    saloon

    Join Date
    Jun 2009
    Location
    GLASGOW
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts
    just checked page 2 and you've solved it with bm parts from the stealer glad its worked i'll have to try it and cross my fingers and toes n hope it works cheers
     
     

  10.  
    #19
    Bimmer Fan
    Car Details
    BIGMILLWARD's Car Details
    Model of Car:
    525i sport
    Year of Manufacture:
    2000
    Transmission Type:
    manual
    Car Body Type:
    saloon

    Join Date
    Jun 2009
    Location
    GLASGOW
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts
    did it effect your window wipers? mine work but they are on intermediate setting on the first 2 setting and then on slow at the 3rd setting, when the speedo is working the 2nd setting seems to be speed controlled going faster as the car gets up to speed. and the abs sensor i used was a cheapo well £50 think it was an obm, i know they don't last as long as the original parts but should last longer than 5 mins lol.
     
     

  11.  
    #20
    Bimmer Fan
    Car Details
    BIGMILLWARD's Car Details
    Model of Car:
    525i sport
    Year of Manufacture:
    2000
    Transmission Type:
    manual
    Car Body Type:
    saloon

    Join Date
    Jun 2009
    Location
    GLASGOW
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts
    i will have to get it on a diagnostic cose its got more than that wrong with it the parking sensors are not working know and the cars cutting out when i slow down to take a corner or come to a stop and its getting harder to start back up the irritating thing is it will run ok for a day or so and then start playing up again, ow well the joys of motoring lol bought the bmw because i was feed up of problems with my astra n i've got more now.
     
     

Page 2 of 3 FirstFirst 123 LastLast
Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts