1999 E46 318i se fault code p0171.

Notices
 

Thread: 1999 E46 318i se fault code p0171.

Reply to Thread
Page 1 of 13 12345611 ... LastLast
Results 1 to 10 of 121
  1. 1999 E46 318i se fault code p0171. 
    #1
    Platinum BFuk Member
    Car Details
    johnny-c2's Car Details
    Model of Car:
    330ci
    Year of Manufacture:
    2002
    Transmission Type:
    auto
    Car Body Type:
    convertible
    johnny-c2's Avatar
    Join Date
    Mar 2010
    Location
    Burnley, Greater Lancashire!
    Posts
    264
    Thanks
    870
    Thanked 378 Times in 237 Posts
    Hi guys,

    I thought i would post this to try and help out other people with similar fault.
    First off last year I got fault code p0171 with management light on,so i went searching and found egr start fan had exploded,so I changed that,cleared code and it seemed o.k for 2 days but then it came back on
    so checked it was the same code,yes it was so went looking again and found the crankcase breather hose had turned into Plasticine,so i changed that cleared codes again spot on the light stayed off,until last week mil back on (same code again) so after more searching and checking of hoses i found the disa valve diaphragm was split (you have to look carefully to see it) through where the bar goes in but it was there,i will try to get some photos on soon.
    If this helps just one person its worthwhile.
     
     

  2. The Following 5 Users Say Thank You to johnny-c2 For This Useful Post:

    328mark (28-03-2010), dailydoggy (28-03-2010),gazzer01278 (18-07-2010),juicy10 (13-04-2010),steve23002 (28-03-2010)

  3. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  4.  
    #2
    BFuk Legend
    Car Details
    steve23002's Car Details
    Model of Car:
    530i Sport
    Year of Manufacture:
    2002
    Transmission Type:
    Auto
    Car Body Type:
    Saloon
    steve23002's Avatar
    Join Date
    Nov 2008
    Location
    Buckingham
    Posts
    11,712
    Thanks
    8,589
    Thanked 8,379 Times in 5,803 Posts
    Quote Originally Posted by johnny-c2 View Post
    Hi guys,

    I thought i would post this to try and help out other people with similar fault.
    First off last year I got fault code p0171 with management light on,so i went searching and found egr start fan had exploded,so I changed that,cleared code and it seemed o.k for 2 days but then it came back on
    so checked it was the same code,yes it was so went looking again and found the crankcase breather hose had turned into Plasticine,so i changed that cleared codes again spot on the light stayed off,until last week mil back on (same code again) so after more searching and checking of hoses i found the disa valve diaphragm was split (you have to look carefully to see it) through where the bar goes in but it was there,i will try to get some photos on soon.
    If this helps just one person its worthwhile.
    Thanks for letting us know Johnny. It may help someone else in the future mate....
     
     

  5.  
    #3
    BMW Crazed
    Car Details
    markyp's Car Details
    Model of Car:
    318 SE
    Year of Manufacture:
    1999
    Transmission Type:
    Manual
    Car Body Type:
    Touring
    markyp's Avatar
    Join Date
    May 2009
    Location
    York
    Posts
    230
    Thanks
    52
    Thanked 45 Times in 41 Posts
    Hi Johnny, was there a pattern to when the engine management light came on? On my car it allways seems to occur after a decent run when I come to idle.
    The PEAKE code reader says "examine fuel system", but I've got into habit of just resetting it.
     
     

  6. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  7.  
    #4
    Platinum BFuk Member
    Car Details
    johnny-c2's Car Details
    Model of Car:
    330ci
    Year of Manufacture:
    2002
    Transmission Type:
    auto
    Car Body Type:
    convertible
    johnny-c2's Avatar
    Join Date
    Mar 2010
    Location
    Burnley, Greater Lancashire!
    Posts
    264
    Thanks
    870
    Thanked 378 Times in 237 Posts
    Quote Originally Posted by markyp View Post
    Hi Johnny, was there a pattern to when the engine management light came on? On my car it allways seems to occur after a decent run when I come to idle.
    The PEAKE code reader says "examine fuel system", but I've got into habit of just resetting it.
    it seemed to be after a run,but not always,it came on most often after acelerating to join the motorway (but not when accelerating)but then yesterday i was just coasting down a hill and on it came.so it got me on one then and i took it to bits.

    after the light came on it was like i had four big lads in the back,the had very poor pull.
     
     

  8. The Following User Says Thank You to johnny-c2 For This Useful Post:

    markyp (28-03-2010)

  9.  
    #5
    Platinum BFuk Member
    Car Details
    johnny-c2's Car Details
    Model of Car:
    330ci
    Year of Manufacture:
    2002
    Transmission Type:
    auto
    Car Body Type:
    convertible
    johnny-c2's Avatar
    Join Date
    Mar 2010
    Location
    Burnley, Greater Lancashire!
    Posts
    264
    Thanks
    870
    Thanked 378 Times in 237 Posts
    The part number for this valve is "11611438404" and it cost me £127 inc. vodka & tonic (not as bad as i though it would be) it takes about 30 mins to change if you have the tools needed.
     
     

  10. bloody light back on 
    #6
    Platinum BFuk Member
    Car Details
    johnny-c2's Car Details
    Model of Car:
    330ci
    Year of Manufacture:
    2002
    Transmission Type:
    auto
    Car Body Type:
    convertible
    johnny-c2's Avatar
    Join Date
    Mar 2010
    Location
    Burnley, Greater Lancashire!
    Posts
    264
    Thanks
    870
    Thanked 378 Times in 237 Posts
    well guys just an update for you all,after a week of no light,car going very very well,i went out tonight for a drive and.......its back!
    i did drive it really hard, then when i chilled out ping on came the light???
    so i went home plugged it in and got code p0170 this time,(had to be day before i go back to work) i have checked all the hoses and pipes,new disa,all thats left is maf?? or o2 sensors??
    i think its time to send this bloody car to a new owner,bring on my 330 convertable.
    when i locate whats causing the light i will post back,or if anyone has any ideas im all ears.

    cheer's
    John.
     
     

  11. The Following User Says Thank You to johnny-c2 For This Useful Post:

    juicy10 (12-04-2010)

  12.  
    #7
    BMW Fanatic
    Car Details
    juicy10's Car Details
    Model of Car:
    318
    Year of Manufacture:
    2000
    Transmission Type:
    manual
    Car Body Type:
    saloon

    Join Date
    Apr 2010
    Location
    gibraltar
    Posts
    47
    Thanks
    18
    Thanked 3 Times in 3 Posts
    hi had similar problem, only thing left to check maf too. had this light on for years if its not the maf it could also b ignition coils? anyone checked this???? thanks
     
     

  13.  
    #8
    Bimmer Fan
    Join Date
    Jul 2008
    Location
    Middlesex
    Posts
    11
    Thanks
    1,817
    Thanked 7,115 Times in 5,338 Posts
    If it is running too lean, then you will have to check the MAF and O2 sensors since you have been round the engine checking for air leaks. Also, I have heard a dirty fuel filter can cause this code to crop up on occasions.
     
     

  14. The Following User Says Thank You to xXNealXx For This Useful Post:

    johnny-c2 (14-04-2010)

  15. too lean 
    #9
    Bimmer Fan
    Car Details
    gazzer01278's Car Details
    Model of Car:
    318i
    Year of Manufacture:
    2000
    Transmission Type:
    manual
    Car Body Type:
    tourer

    Join Date
    Jul 2010
    Location
    somerset
    Posts
    23
    Thanks
    2
    Thanked 1 Time in 1 Post
    how did you get on in the end as ive the same problem
     
     

  16.  
    #10
    BMW Guru
    Car Details
    Ronnie's Car Details
    Model of Car:
    See above
    Year of Manufacture:
    Never too old, never too new
    Transmission Type:
    Always manual
    Car Body Type:
    Usually 5 doors
    Ronnie's Avatar
    Join Date
    Dec 2007
    Location
    Bournemouth, Dorset.
    Posts
    20,394
    Thanks
    6,198
    Thanked 7,051 Times in 5,322 Posts
    Sounds like a lambda sensor fault, if you get the proper BMW fault codes read and get the live data checked out it will help in diagnosing the problem.
     
     

Page 1 of 13 12345611 ... LastLast

LinkBacks (?)


Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts