Starting problem Z3 2001.

Notices
 

Thread: Starting problem Z3 2001.

Reply to Thread
Results 1 to 2 of 2
  1. Starting problem Z3 2001. 
    #1
    Bimmer Fan
    Car Details
    ijdavie's Car Details
    Model of Car:
    Z3 3.0i
    Year of Manufacture:
    2001
    Transmission Type:
    Manual
    Car Body Type:
    Convertible

    Join Date
    Jul 2012
    Location
    Edinburgh
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Right guys this is my first ever post. :-) just wish it was under better circumstances.

    i bought a BMW z3 about 2 months ago. having checked over it and only seeing some small issues nothing which could cause a problem for starting just small things due to its age..

    last week i hit a non starting problem. the effects sound like the engine is not getting any fuel which i think is part of the case. so

    I have checked the battery which is fine.
    I have checked the cables that run to the fuel pump which are not fine. 4 cables (2 earth and 2 live, im guessing. ) which one group of the cables has a constant run of power. the other has none when i turn the key to position 2.


    after this i went on the hunt for the relay which is killing me as i have been told it could be in three places, glove box, centre console and the fuse box in the engine bay. i have been in the glove box with finding nothing. anyone tell me where this relay is on this car ?

    also one thing that is bothering me which someone might shed a light on. when i turn the key to position 2. the pump is not firing up. however the lights on the speedo are not doing there normal. im only getting the miles and the what looks like the air bag check light. am i right in saying there is more that should turn on at position 2.

    anyone that could shed a bit of light, allowing me to get this wee car back on the road i would be over the moon.

    Cheers guys
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    Bimmer Fan
    Car Details
    ijdavie's Car Details
    Model of Car:
    Z3 3.0i
    Year of Manufacture:
    2001
    Transmission Type:
    Manual
    Car Body Type:
    Convertible

    Join Date
    Jul 2012
    Location
    Edinburgh
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Right I have development. I finally found the Relay for the fuel filter which i think was at fault. pulled it and gave it a clean and wham she started. however i now have what looks like the warning light (just left of the handbrake light) and the Traction control light on. im guessing that the warning light is to let me know that the traction control has failed. but the question is why ? could that have something to do with me pulling the relay for the fuel filter ???

    any help would be awesome. cheers guys.


    also a big thank you to brian4, for filling me in on where the fuel relay was kept. :-)
     
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts