Powered roof problems - Z3.3.0i - this problem not already on this forum!

Notices
 

Thread: Powered roof problems - Z3.3.0i - this problem not already on this forum!

Reply to Thread
Results 1 to 2 of 2
  1. Powered roof problems - Z3.3.0i - this problem not already on this forum! 
    #1
    Bimmer Fan
    Car Details
    Dope's Car Details
    Model of Car:
    Z3 3.0i
    Year of Manufacture:
    2001
    Transmission Type:
    Manual
    Car Body Type:
    Roadster

    Join Date
    Mar 2012
    Location
    UK
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hi - first post here - trying to help out my girlfriend with her Z3 3.0i...

    The symptoms are that the powered roof stopped opening.

    However it will still close. If I undo the bypass screw on the reservoir and open the roof manually, then close the screw back up tight, shut the boot, ignition on, foot on brake, press 'roof close' button it does as it should and closes all the way.

    Weirdly I noticed that if I press 'roof open' button when it's already open it also closes.

    The fluid in the reservoir is almost up to the correct mark when the roof is in the open position.

    I have swapped the relays near the reservoir around and it made no difference.

    The brake pedal triggers the brake lights.

    The microswitch above the passenger window makes a convincing click sound.

    The cable running back through the mechanism on the passenger side appears intact.

    I popped the rocker off the 'roof open/close' switch and operated the microswitches manually and it did the same.


    Any thoughts? Is there some kind of reset procedure I can do on a Z3?


    Thanks in advance!!
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    Moderator
    Car Details
    edber's Car Details
    Model of Car:
    E60 520D LCI
    Year of Manufacture:
    2007
    Transmission Type:
    AUTOMATIC
    Car Body Type:
    saloon
    edber's Avatar
    Join Date
    Mar 2012
    Location
    South ireland
    Posts
    4,964
    Images
    6
    Thanks
    637
    Thanked 690 Times in 647 Posts
    i dont know if this is any good to you but my 01 320d sunroof woudnt close fully on its own,it was as if it was sensing a blockage and would bounce back a few inches,anyway i found a thread which suggested that with the ignition on,car not started,i press the centre of the sunroof switch which is the tilt and hold for 20 to 30 seconds and release,then press again and hold for 20 to 30 seconds and then ignition off and then put ignition to acc and try sunroof.my sunroof has never closed fully on its own in the two years i own the car and today i did that reset trick and guess what!!!yep sunroof closed on its own.hope this helps you.
     
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts