No power to maf and other problems. PLEASE HELP!!

Notices
 

Thread: No power to maf and other problems. PLEASE HELP!!

Reply to Thread
Results 1 to 4 of 4
  1. No power to maf and other problems. PLEASE HELP!! 
    #1
    Bimmer Fan
    Car Details
    lawsonn2003's Car Details
    Model of Car:
    318i se
    Year of Manufacture:
    1998
    Transmission Type:
    manual
    Car Body Type:
    saloon

    Join Date
    Jan 2014
    Location
    Dudley
    Posts
    14
    Thanks
    0
    Thanked 0 Times in 0 Posts
    ok i got a bmw 318I e46 98. Was running really really rough so i unpluged maf and ran better and had loads of power.
    I fitted a new £130 maf in the rain today and think the plug may have been wet because i started it up and it wouldn't start. pluged or un pluged. i checked power to it and no 12v feed. I hooked a 12v feed to it and car started up but running worse then before and wont rev past 3000 rpm. And... you turn ignition on and the temp gauge goes right into red and fans stay on even though its cold :/ and tryed to drive it and the mpg was so bad i couldnt belive. unhook the 12v and car wont start and temp goes back to normal.

    Please help!! i have looked at the fuses in car and the engine fuses and all is fine. Im worryed that water has mixed with live and neg and has done something.
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    Moderator
    Car Details
    edber's Car Details
    Model of Car:
    E60 520D LCI
    Year of Manufacture:
    2007
    Transmission Type:
    AUTOMATIC
    Car Body Type:
    saloon
    edber's Avatar
    Join Date
    Mar 2012
    Location
    South ireland
    Posts
    4,975
    Images
    6
    Thanks
    640
    Thanked 691 Times in 648 Posts
    Put in the new maf and jump start the car from the jumping points under the bonnet and see how the car drives.
     
     

  4.  
    #3
    Bimmer Fan
    Car Details
    lawsonn2003's Car Details
    Model of Car:
    318i se
    Year of Manufacture:
    1998
    Transmission Type:
    manual
    Car Body Type:
    saloon

    Join Date
    Jan 2014
    Location
    Dudley
    Posts
    14
    Thanks
    0
    Thanked 0 Times in 0 Posts
    where are the jumping points sorry? and the battery is perfect and car turns over just does not start unless i put a 12v to the red wire on the maf plug
     
     

  5. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  6.  
    #4
    Moderator
    Car Details
    edber's Car Details
    Model of Car:
    E60 520D LCI
    Year of Manufacture:
    2007
    Transmission Type:
    AUTOMATIC
    Car Body Type:
    saloon
    edber's Avatar
    Join Date
    Mar 2012
    Location
    South ireland
    Posts
    4,975
    Images
    6
    Thanks
    640
    Thanked 691 Times in 648 Posts
    Ok I understand better now but that scenario of putting 12v to the maf plug to get the car started is extremely odd.
    Sorry I cant help more.
     
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts