n46b20a 318i vanos solenoid errors

Notices
 

Thread: n46b20a 318i vanos solenoid errors

Reply to Thread
Results 1 to 2 of 2
  1. n46b20a 318i vanos solenoid errors 
    #1
    Bimmer Fan
    Car Details
    Driftworkz's Car Details
    Model of Car:
    325
    Year of Manufacture:
    2004
    Transmission Type:
    Maual
    Car Body Type:
    Saloon

    Join Date
    Dec 2013
    Location
    Berkshire
    Posts
    12
    Thanks
    0
    Thanked 1 Time in 1 Post
    hiya i recently had the pleasure of taking delivery of the above car in for repair at my shop

    the initial fault codes after relearning the valvetronic stops were as follows

    intake cam control
    intake cam sensor

    i quickly swapped the exhaust & intake cam sensors over, no difference in codes. I then swapped the vanos solenoids over & again no change in codes

    I should have walked away from the job here

    But unfortunately i decided to remove the rocker cover and check timing, £100 pound later i received the relevant tools which i offered up to the cams, the inlet cam timing was out considerably & there was tipex all over the cams . My assumption is that this engine has been damaged previously and obviously still isn't right.

    After I had re timed the engine & again relearned the valvetronic stops i took it for a test drive and noted low power & deep intake sucking (like its got a blocked air filter . I then checked for codes & have

    intake vanos control
    exhaust vanos control

    I then decided to recheck the timing again & its perfect hence the no cam sensor fault but in regards to the vanos errors im a bit reluctant to change them both as i don't think they are faulty.

    so to my questions

    Does the vanos need some type of adaption/initialization/set-up?
    Any one have any ideas where to go from here?

    thanks in advance

    Matt
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    Bimmer Fan
    Car Details
    Driftworkz's Car Details
    Model of Car:
    325
    Year of Manufacture:
    2004
    Transmission Type:
    Maual
    Car Body Type:
    Saloon

    Join Date
    Dec 2013
    Location
    Berkshire
    Posts
    12
    Thanks
    0
    Thanked 1 Time in 1 Post
    a bit of an update both vanos solenoids have the same resistance around 15ohms

    today a code popped up for the valvetronic motor, i tested the resistance from the pins to body i have 1708 ohms resistance so i assume the motor has a short although a high resistance short to ground, but could this be the cause of my other faults? & should this be replaced now?
     
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts