My first BMW, day one of owning and has broke already!

Notices
 

Thread: My first BMW, day one of owning and has broke already!

Reply to Thread
Page 1 of 2 12 LastLast
Results 1 to 10 of 11
  1. My first BMW, day one of owning and has broke already! 
    #1
    Bimmer Fan
    Car Details
    jobee87's Car Details
    Model of Car:
    330d
    Year of Manufacture:
    2001
    Transmission Type:
    Automatic
    Car Body Type:
    Touring

    Join Date
    Jul 2013
    Location
    North Wales
    Posts
    6
    Thanks
    2
    Thanked 0 Times in 0 Posts
    Hi everyone! as the title says, i have bought my first BMW today! very proud until halfway home from buying it. It is a 330d touring 2001 with 108k on the clock, it drives perfect! until 2 hours after i bought it.

    i first noticed that the indicators were not flashing on the dash, tryed the hazards and they blinked on and off as they do but no green lights on the dash. (indicators were working on the outside at this point)

    as i pulled up on the drive i seen the headlights were on, strange the switch is off??

    now after popping out to the shop the lights are always on with the ignition, and not even the hazards work.

    i disconnected the battery and left it for five mins, reconnected and everything was perfect, lights were off, put them on auto and they came on and adjusted themselves as they should, hazards work and indicators but still no green lights on the dash. after a drive it was back to nothing working and headlights on.

    came on the forum to see if any one has had this before and noticed alot of problems with ipod connectors with the radio causing very simular problems, so checked to see if mine had one fitted. nope it doesnt and the cd changer is missing! lead just lying in the boot were it goes.

    went back out to disconnect the battery again, left it off for ten mins and put a test on the battery, 12.8v and then connected back up, started car and it has a good 13.6v there, but this time after been disconnected, the indicators and hazards still do not work and the lights are constantly on with the ignition on.

    sorry to go on, also two buttons on the steering wheel does not work, it has a face talking on it and t/r? every other button works. what are these two supposed to do?

    forgot to mention full beam does not work when the headlights are permently on also. i have checked all the fuses.

    any help would be greatly appreciated!

    many thanks!! tom
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    Bimmer Fan
    Car Details
    jobee87's Car Details
    Model of Car:
    330d
    Year of Manufacture:
    2001
    Transmission Type:
    Automatic
    Car Body Type:
    Touring

    Join Date
    Jul 2013
    Location
    North Wales
    Posts
    6
    Thanks
    2
    Thanked 0 Times in 0 Posts
    just been out to it now, battery disconnected and reconnected and everything worked for 60 seconds! auto lights, dash lights, indicators and i noticed the fan continued a little after the ignition went off. went into the house to tell wife that i was going to take it for a drive, went back to start it and the lights came straight on with the ignition again, even tho they are switched off! indicators wont work, no dash lights.

    what is tripping out? and going to a limp mode? is there a ecu that controls all these items? wipers are never affected nor radio or air con?

    any help would be great! cheers tom!
     
     

  4.  
    #3
    Bimmer Fan
    Car Details
    320d03's Car Details
    Model of Car:
    e46 320d
    Year of Manufacture:
    2003
    Transmission Type:
    manual
    Car Body Type:
    saloon

    Join Date
    Feb 2013
    Location
    plymouth
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Could be a fuse fingers crossed its sonemthing simple and cheap
    Give the dealers a call
     
     

  5. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  6.  
    #4
    Super Moderator
    Car Details
    dailydoggy's Car Details
    Model of Car:
    330i
    Year of Manufacture:
    2001
    Transmission Type:
    manual
    Car Body Type:
    saloon
    dailydoggy's Avatar
    Join Date
    Sep 2009
    Location
    UK
    Posts
    12,420
    Thanks
    1,817
    Thanked 5,259 Times in 4,090 Posts
    could be a dodgy ignition barrel they are known to cause things not working on dash n stuff and its a common fault...but it sounds more grizzly than that to me...
    330i sport a big chunk of berlin...

     
     

  7.  
    #5
    Bimmer Fan
    Car Details
    jobee87's Car Details
    Model of Car:
    330d
    Year of Manufacture:
    2001
    Transmission Type:
    Automatic
    Car Body Type:
    Touring

    Join Date
    Jul 2013
    Location
    North Wales
    Posts
    6
    Thanks
    2
    Thanked 0 Times in 0 Posts
    Update on today's progress......

    Went out this morning and checked everything over again, fuses etc.
    Found the negative terminal was slightly loose, so tightened it up.
    Started up and off I went, everything worked perfect!! Just like on the test drive, half hour up the road the cruise control stopped,
    Weird I thought? Maybe I caught the brake pedal and knocked it off? Tryed indicator and surprise surprise no green arrows on the
    Dash, but indicators working on the outside. Got to my destination and locked car up, returned to car hour and a half later to it all working, but for only 5 minutes. Indicators on dash stopped again! Got home and went in for a hour then decided to start taking things apart, I found a very hacked up Nokia device wired into the stereo harness, bingo! I thought that would be it, took it out and now the central locking locks the car all the time! Unless the drivers door is open? Just been init now to the garage and the mainbeam is stuck permantly on, even tho it's turned off.

    Could this be the doings of the ignition barrel? I am thinking it could be the gmc? General control module?

    Cheers Tom!
     
     

  8.  
    #6
    Super Moderator
    Car Details
    dailydoggy's Car Details
    Model of Car:
    330i
    Year of Manufacture:
    2001
    Transmission Type:
    manual
    Car Body Type:
    saloon
    dailydoggy's Avatar
    Join Date
    Sep 2009
    Location
    UK
    Posts
    12,420
    Thanks
    1,817
    Thanked 5,259 Times in 4,090 Posts
    ide be checking all the earth terminals on the car, ignition barrel things usually dont work at all not stuff sticking on...

    its gonna be summat really obvious or a total mare by the sounds of it...
    330i sport a big chunk of berlin...

     
     

  9.  
    #7
    BMW Fanatic
    Car Details
    mikeaj's Car Details
    Model of Car:
    750
    Year of Manufacture:
    1999
    Transmission Type:
    auto
    Car Body Type:
    saloon

    Join Date
    May 2012
    Location
    Rugby
    Posts
    68
    Thanks
    8
    Thanked 6 Times in 6 Posts
    You have to plug it in to sensible diagnostics, otherwise you are peeing in the wind. Lots of "experts" who can fix it but don't know what they are doing, I think the guys who replied already will agree. AN example, my son-in-laws E46 radio kept failing. Diagnostics didn't show any errors. It came on when he shut the door hard. I stripped the door, remade all the speaker connections and bingo! it's worked ever since. The "CAN bus" or network sensed the fault and shut down the radio to prevent damage.
    Look for any water stains, dampness, overheating etc. Make certain that every fuse and plug is clean clean clean. Maplin do some useful sprays. You might not find the fault, but you might fix it, if you follow!
    It is worth it, especially for a 30D.
    Mike
     
     

  10. The Following User Says Thank You to mikeaj For This Useful Post:

    jobee87 (07-07-2013)

  11.  
    #8
    Super Moderator
    Car Details
    dailydoggy's Car Details
    Model of Car:
    330i
    Year of Manufacture:
    2001
    Transmission Type:
    manual
    Car Body Type:
    saloon
    dailydoggy's Avatar
    Join Date
    Sep 2009
    Location
    UK
    Posts
    12,420
    Thanks
    1,817
    Thanked 5,259 Times in 4,090 Posts
    most ECU low voltage controlled stuff is negative switched so if a car developes shorts to earth in the negative wiring it switches these things on, because they are fed permanant with a voltage normally and the ECU just completes the circuit by giving the negative a physical switch to earth usually via a relay, as they are negative earth cars it is effectively bypassing the ECU control and permanantly switching stuff on if there is short in any of the neg side wiring before the switch...


    INPA diagtnostics may help but it sounding more like the job of an auto electrician but it still could be summat very simple as its so intermitant...


    http://www.bimmerforums.co.uk/forum/...winxp-t102843/
    330i sport a big chunk of berlin...

     
     

  12. The Following User Says Thank You to dailydoggy For This Useful Post:

    jobee87 (07-07-2013)

  13.  
    #9
    Bimmer Fan
    Car Details
    shadwell's Car Details
    Model of Car:
    330cd
    Year of Manufacture:
    2005
    Transmission Type:
    auto
    Car Body Type:
    coupe
    shadwell's Avatar
    Join Date
    Jun 2011
    Location
    brockenhurst
    Posts
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts
    bugger lets hope that's not going to happen to me
    now this is what I use on the weekends
     
     

  14.  
    #10
    Moderator
    Car Details
    edber's Car Details
    Model of Car:
    E60 520D LCI
    Year of Manufacture:
    2007
    Transmission Type:
    AUTOMATIC
    Car Body Type:
    saloon
    edber's Avatar
    Join Date
    Mar 2012
    Location
    South ireland
    Posts
    4,953
    Images
    6
    Thanks
    636
    Thanked 689 Times in 646 Posts
    Id start by borrowing a LIGHT CONTROL MODULE if you can and swap it over and see what happens.
    If you know of a friendly breaker who will let you swap the unit on site(will only take a few minutes to swap out).
    If it works then you can code the unit to your car with software and a cable.
     
     

Page 1 of 2 12 LastLast
Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts