Keeps blowing stater/temp guege/fuel gauge 15amp fuse?

Notices
 

Thread: Keeps blowing stater/temp guege/fuel gauge 15amp fuse?

Reply to Thread
Results 1 to 2 of 2
  1. Keeps blowing stater/temp guege/fuel gauge 15amp fuse? 
    #1
    BMW Crazed
    Car Details
    spitfire123's Car Details
    Model of Car:
    318
    Year of Manufacture:
    1996
    Transmission Type:
    manual
    Car Body Type:
    saloon

    Join Date
    Aug 2011
    Location
    N.london
    Posts
    204
    Thanks
    22
    Thanked 9 Times in 9 Posts
    Hi all,
    had a fuse blow 3 times today, they last about 5 mins then blow.

    its fuse number 44 i belive?

    basicly its the one that does the fuel and temp gauge. also when it blows i cant start the car? put a fresh one in it starts 1st time?

    any advice?

    cheers
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    Diamond BFuk Member
    Car Details
    petrolmarty's Car Details
    Model of Car:
    530d M Sport
    Year of Manufacture:
    2006 December
    Transmission Type:
    automatic
    Car Body Type:
    saloon
    petrolmarty's Avatar
    Join Date
    Sep 2010
    Location
    Essex
    Posts
    1,213
    Thanks
    140
    Thanked 438 Times in 377 Posts
    Fuses are a safety valve, there isn't much point in keep putting fuses in if the original fault remains. You need to get it checked out and have any fault codes read.
     
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts