Indicator issue

Notices
 

Thread: Indicator issue

Reply to Thread
Results 1 to 2 of 2
  1. Indicator issue 
    #1
    Bimmer Fan
    Car Details
    Rjackson's Car Details
    Model of Car:
    330ci
    Year of Manufacture:
    2001
    Transmission Type:
    Automatic
    Car Body Type:
    Convertible

    Join Date
    May 2013
    Location
    Saxmundham
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I've got a convertible 330ci MSport and have had an issue with the drivers side indicator, however I have checked all the bulbs and cleaned all of the terminals up there seems no history of earthing on the wires or corrosion ... I'm thinking it maybe the relay but I thought I would post here first to see if any one else had this issue?
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    BMW Fanatic
    Car Details
    TheMadWelshman's Car Details
    Model of Car:
    316i
    Year of Manufacture:
    1996
    Transmission Type:
    manual
    Car Body Type:
    Coupe
    TheMadWelshman's Avatar
    Join Date
    Nov 2008
    Location
    Anglesey, Wales
    Posts
    37
    Thanks
    2
    Thanked 2 Times in 2 Posts
    I had a similar issue in my e36 i punched the lens about three weeks ago and its been ok since then and id checked everything as well. Weird or what.... Iknow its not much help but you never know. Mine was the exact same one also.::
     
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts