heater problems

Notices
 

Thread: heater problems

Reply to Thread
Results 1 to 4 of 4
  1. heater problems 
    #1
    Bimmer Fan
    Car Details
    Static_Stef's Car Details
    Model of Car:
    325i
    Year of Manufacture:
    1999
    Transmission Type:
    manual
    Car Body Type:
    Touring

    Join Date
    Nov 2013
    Location
    Crewe, Cheshire
    Posts
    9
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hi guys.
    I've recently bought a 318i touring with an M50 2.5 conversion.
    The car has climate control and all buttons and display works. But the heaters or dash blowers dont work. Ive read tjat the cabin filter can sometimes cause this so I swapped this the other day. The filter looked like it had never been changed as it was black. But still no difference. The hheaters do somehow work when at high speed. I.e. motorway speed.
    Anyone be able to shine some light on the issue.
    Any help would be much appreciated, cheers.
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    Moderator
    Car Details
    edber's Car Details
    Model of Car:
    E60 520D LCI
    Year of Manufacture:
    2007
    Transmission Type:
    AUTOMATIC
    Car Body Type:
    saloon
    edber's Avatar
    Join Date
    Mar 2012
    Location
    South ireland
    Posts
    4,973
    Images
    6
    Thanks
    638
    Thanked 691 Times in 648 Posts
    It could be the final stage resistor AKA the hedgehog.
    But I presume you have checked fuses.
    There is a big red 50amp fuse in the glovebox that feeds the blower.
     
     

  4.  
    #3
    Bimmer Fan
    Car Details
    Joey Figo's Car Details
    Model of Car:
    330ci msport
    Year of Manufacture:
    2002
    Transmission Type:
    auto
    Car Body Type:
    coupe

    Join Date
    Apr 2013
    Location
    South Coast UK
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Had exact same issue. Was the hedgehog. Dont buy a cheap 20 notes one off ebay cos it will ladt 6 months and die again like mine did. Got oem one now and all sorted. Paid 47 for mine and mate fitted for a tenner. 45 mins work to someone who has done it before
     
     

  5. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  6.  
    #4
    Bimmer Fan
    Car Details
    Static_Stef's Car Details
    Model of Car:
    325i
    Year of Manufacture:
    1999
    Transmission Type:
    manual
    Car Body Type:
    Touring

    Join Date
    Nov 2013
    Location
    Crewe, Cheshire
    Posts
    9
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Yeah I did think it would be the final stage resistor! I'll have a look soon for one. Where are they located?
     
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts