E87 120i sport Engine won't START - new CAS EWS and ECU (dme)

Notices
 

Thread: E87 120i sport Engine won't START - new CAS EWS and ECU (dme)

Reply to Thread
Results 1 to 7 of 7
  1. E87 120i sport Engine won't START - new CAS EWS and ECU (dme) 
    #1
    Bimmer Fan
    Car Details
    seefo's Car Details
    Model of Car:
    e87 120i sport
    Year of Manufacture:
    2005
    Transmission Type:
    Manual
    Car Body Type:
    Hatch

    Join Date
    Nov 2011
    Location
    Nottingham
    Posts
    11
    Thanks
    1
    Thanked 0 Times in 0 Posts
    hi everyone.

    i'm having some problems with getting my car started if anyone can help.

    i purchased a salvage 120i sport a few months ago.
    it was a non runner and needed a key. I was just going to order the key when i noticed that the cas unit had been removed and so i needed a key and cas unit (and was unsure about any faults in the DME) (so keys and Cas alone about 350+ for both bmw direct)

    so instead i purchased an identical DME EWS CAS unit and key from a fella in Germany. all the part numbers match up identically and i was so lucky to get the lot for £250 (except that the ews slot is for LH drive - i can sort that out!)

    at the moment, when i put the key in the idrive pops up and everything appears to work fine (windows, parking lights, alarm, nav stereo etc)

    the problem is the car wont start, nothing happens when i press the start button apart from the idrive going up and down into the dash.
    i drive comes up with 'head unit not coded properly'
    a yellow sign stating ELV- move steering wheel- sometimes turns red but the steering does move okay.....

    but all the stereo bottons on steering wheel work fine- they did not at first- but i cleared some errors using INPA and now they do)

    i am so worried there is a major problem with the engine.

    at first i thought it was the battery (apparently low voltage meant that the car wouldn't even bother firing)- but i put another cars battery in there and still no luck.

    questions that i want to ask is that- is there any coding that is required before the car will try to fire up?

    I'm new to these forums but if anyone is so kind to find me a solution that i can do and fix it myself i am willing to donate £30 to the forums

    I've spent £100s sourcing parts for this car and taking it to a professional will mean it may stand me at more expensive than it would be to have bought it perfect.

    I'm a student at uni and thought i'd find time to repair it and it would be cost effective to do (paying my own fees :( ....)

    Any help will be much appreciated.
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    Premium Member
    Car Details
    matthew_henson's Car Details
    Model of Car:
    E61 525d Touring
    Year of Manufacture:
    2005
    Transmission Type:
    Manual
    Car Body Type:
    Touring/Estate
    matthew_henson's Avatar
    Join Date
    Mar 2011
    Location
    Forest Of Dean
    Posts
    4,210
    Thanks
    904
    Thanked 1,412 Times in 1,223 Posts
    You need probably need to sync the EWS to DME which you can do in INPA, if they lose sync the car won't start. The imobiliser is in the DME which needs to correspond the key logged with the CAS, you say you replaced the CAS, EWS and DME and had the matching key so you should be OK. I have however seen people take the locks as well.

    In later BMW's the CAS and EWS were intergrated but the DME still needed to know the ID of the key to start, one of the member called assimilator1 knows this stuff, you may want to PM him
     
     

  4.  
    #3
    Bimmer Fan
    Car Details
    seefo's Car Details
    Model of Car:
    e87 120i sport
    Year of Manufacture:
    2005
    Transmission Type:
    Manual
    Car Body Type:
    Hatch

    Join Date
    Nov 2011
    Location
    Nottingham
    Posts
    11
    Thanks
    1
    Thanked 0 Times in 0 Posts
    don't you think they will already be syncd?
    They are a whole set from another 120i (same year same spec)

    I was going to sync on INPA ( i know where the option to sync EWS and DMW is but i'm afraid of bodging it all up! )
    Do you know how long it takes to do it as my garage has no electricity so i don't want my laptop to go dead during a sync!
     
     

  5. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  6.  
    #4
    Bimmer Fan
    Car Details
    seefo's Car Details
    Model of Car:
    e87 120i sport
    Year of Manufacture:
    2005
    Transmission Type:
    Manual
    Car Body Type:
    Hatch

    Join Date
    Nov 2011
    Location
    Nottingham
    Posts
    11
    Thanks
    1
    Thanked 0 Times in 0 Posts
    hi can anyone else help me please!!
     
     

  7.  
    #5
    BMW Guru
    Car Details
    Assimilator1's Car Details
    Model of Car:
    330d SE 184 bhp
    Year of Manufacture:
    11/2001
    Transmission Type:
    Manual
    Car Body Type:
    Saloon

    Join Date
    Sep 2010
    Location
    UK,Surrey,Guildford
    Posts
    2,406
    Thanks
    238
    Thanked 288 Times in 270 Posts
    Hi, I'm afraid I've had very little to do with these kind of problems, beyond what Matthew has already said about re-synching I'm afraid I can't really help.
    There was a recent-ish thread about this in the e46 forum where someone had to re-synch, the info there might be useful.
    Btw I can't see that you could make it worse than it already is by trying it!

    Can't you get an extension lead to the garage?

    Matthew
    I think you must be thinking of someone else as I've had no hands on experience doing this .
    Maybe it was DD?
    Helping scientific research with just my PC via Distributed Computing - Skynet-POGS, Asteroids@Home, Folding@H, Rosetta@H, MilkyWay@H, LHC@H, SETI@H & Muon1 - Team AnandTech .
    Projects list https://en.wikipedia.org/wiki/List_of_distributed_computing_projects



    http://www.fuelly.com/driver/assimilator1/330d
     
     

  8.  
    #6
    Bimmer Fan
    Car Details
    seefo's Car Details
    Model of Car:
    e87 120i sport
    Year of Manufacture:
    2005
    Transmission Type:
    Manual
    Car Body Type:
    Hatch

    Join Date
    Nov 2011
    Location
    Nottingham
    Posts
    11
    Thanks
    1
    Thanked 0 Times in 0 Posts
    hi again
    im having problems with inpa- my version is in German (some parts) and when i try cas dme or dme ews sync i get errors.
    I am in the process of installing DIS v47
    any idea how to do the sync with DIS. I spoke to a technician and he was reluctant to say that the car would work because the DME EWS CAS and key are from a different car.
    will i have to code the rest of the car?
    Im having a trawl through Auto electricals but wondering whether any one has done this before?! Dis is supposed to be more pwerful and i don't want anything to go wrong!
    kind regards
     
     

  9.  
    #7
    Bimmer Fan
    Car Details
    seefo's Car Details
    Model of Car:
    e87 120i sport
    Year of Manufacture:
    2005
    Transmission Type:
    Manual
    Car Body Type:
    Hatch

    Join Date
    Nov 2011
    Location
    Nottingham
    Posts
    11
    Thanks
    1
    Thanked 0 Times in 0 Posts
    BUT to use DIS do i need the ignition on?
    this is what im trying to achieve (sync dme/cas/ews so ignition will work!! ) :(
     
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts