e60 idrive frozen help??

Notices
 

Thread: e60 idrive frozen help??

Reply to Thread
Results 1 to 4 of 4
  1. e60 idrive frozen help?? 
    #1
    Bimmer Fan
    Car Details
    caspadj3's Car Details
    Model of Car:
    M3
    Year of Manufacture:
    2001
    Transmission Type:
    manual
    Car Body Type:
    convertible

    Join Date
    Nov 2010
    Location
    birmingham
    Posts
    17
    Thanks
    22
    Thanked 4 Times in 4 Posts
    hi all, idrive screen frozen on even after removing key and locking car, cant use any functions screens just froze! was goin to disconnect battery 2 c if that wud reset it but where the hell is the battery??? any help much appreciated thanks
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    Diamond BFuk Member
    Car Details
    petrolmarty's Car Details
    Model of Car:
    530d M Sport
    Year of Manufacture:
    2006 December
    Transmission Type:
    automatic
    Car Body Type:
    saloon
    petrolmarty's Avatar
    Join Date
    Sep 2010
    Location
    Essex
    Posts
    1,213
    Thanks
    140
    Thanked 438 Times in 377 Posts
    Right hand side of the boot I believe. I think there is a reset procedure on the idrive, I'm sure someone will be along soon to advise you.
     
     

  4.  
    #3
    Bimmer Fan
    Join Date
    Jul 2008
    Location
    Middlesex
    Posts
    11
    Thanks
    1,817
    Thanked 7,115 Times in 5,338 Posts
    If you have pro nav then a soft reset of the i-drive by pressing both DVD eject buttons and volume knob simultaneously may not work. Just take the -ve lead off the battery and leave for 5 mins to let the ECU reset itself.
     
     

  5. The Following User Says Thank You to xXNealXx For This Useful Post:

    caspadj3 (31-01-2012)

  6. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  7.  
    #4
    Bimmer Fan
    Car Details
    caspadj3's Car Details
    Model of Car:
    M3
    Year of Manufacture:
    2001
    Transmission Type:
    manual
    Car Body Type:
    convertible

    Join Date
    Nov 2010
    Location
    birmingham
    Posts
    17
    Thanks
    22
    Thanked 4 Times in 4 Posts
    Quote Originally Posted by NealP View Post
    If you have pro nav then a soft reset of the i-drive by pressing both DVD eject buttons and volume knob simultaneously may not work. Just take the -ve lead off the battery and leave for 5 mins to let the ECU reset itself.
    doin the eject thing worked straight away nice1 pal! u dont kno y my dvd hence satnav has never worked either do u?? thanks
     
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts