E60 525D 2007 traction control issue?

Notices
 

Thread: E60 525D 2007 traction control issue?

Reply to Thread
Results 1 to 4 of 4
  1. E60 525D 2007 traction control issue? 
    #1
    BMW Fanatic
    Car Details
    daniel1888's Car Details
    Model of Car:
    525d m sport
    Year of Manufacture:
    2007
    Transmission Type:
    manual
    Car Body Type:
    saloon

    Join Date
    Dec 2012
    Location
    scotland
    Posts
    38
    Images
    3
    Thanks
    3
    Thanked 1 Time in 1 Post
    yesterday the key wouldnt go into the ignition then today i went to my local tescos and just as i was pulling out i heard a bing and the traction control came up aswell as the handbrake light then when you put the handbrake on it came up red just like the picture (not mines). the traction control was definently off because the second you touched the throttle the you could feel it starting to go . When i pressed the traction control button nothing would happen and when i turned the car off and on it was still up until an hour later when it just dissapered. Im only young so i have no idea what it all means( yes i know what it means individually ) but i have no clue as to why it happened
    Attached Images
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    Super Moderator
    Car Details
    payno's Car Details
    Model of Car:
    M3 Evo S Type R
    Year of Manufacture:
    1998 2003
    Transmission Type:
    Manual Auto
    Car Body Type:
    Coupe Saloon
    payno's Avatar
    Join Date
    Feb 2011
    Location
    birmingham city
    Posts
    9,225
    Thanks
    2,085
    Thanked 2,055 Times in 1,893 Posts
    best to get its codes read until then its just guess work
     
     

  4. The Following User Says Thank You to payno For This Useful Post:

    daniel1888 (06-01-2013)

  5.  
    #3
    BMW Fanatic
    Car Details
    daniel1888's Car Details
    Model of Car:
    525d m sport
    Year of Manufacture:
    2007
    Transmission Type:
    manual
    Car Body Type:
    saloon

    Join Date
    Dec 2012
    Location
    scotland
    Posts
    38
    Images
    3
    Thanks
    3
    Thanked 1 Time in 1 Post
    ok from just looking around ive saw that this is a common problem on bmw's but there is never one specific answer so ill ceck the codes
     
     

  6. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  7.  
    #4
    BMW Maestro
    Car Details
    mjojom's Car Details
    Model of Car:
    e61
    Year of Manufacture:
    2004
    Transmission Type:
    A
    Car Body Type:
    T

    Join Date
    Jul 2011
    Location
    UK
    Posts
    713
    Thanks
    240
    Thanked 201 Times in 164 Posts
    you should, could be loads of things. for example on my z4 it was too much of brake fluid in reservoir. on my e61 it was wheel speed/abs sensor. on another Z4 DSC pressure sensor, so list is quite large.
     
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts