E46 possible service light reset method

Notices
 

Thread: E46 possible service light reset method

Reply to Thread
Page 1 of 2 12 LastLast
Results 1 to 10 of 12
  1. E46 possible service light reset method 
    #1
    BMW Master
    Car Details
    mrbarry's Car Details
    Model of Car:
    530d
    Year of Manufacture:
    1999
    Transmission Type:
    manual
    Car Body Type:
    touring
    mrbarry's Avatar
    Join Date
    Dec 2008
    Location
    westmidlands
    Posts
    271
    Thanks
    7
    Thanked 57 Times in 47 Posts
    Any one ever tried this method? I have an E39 but stumbled on this the other day on another site, I could not find this method on here and thought I would post it up.



    BMW Oil Service reset for 2001 ~ current

    No need for reset tool for 2001+ model by: Moko

    BMW insp. reset

    - Iginition OFF (POS 0)

    - Press and Hold the trip odometer button while turning key to position 1 (ACCESSORY)

    - Keep the button depressed (about 5 secs.) until you see "Oil Service" or "Inspection" with "Reset" or "Re" in the display

    - *Note: On vehicles with "High" cluster, you will also see the amount of fuel (in litres) remaining until next service

    - Press the button again and hold for approx. 5 secs. until "Reset" or "Re" flashes

    - While the display is flashing, briefly press the button again to reset the Service Interval. After the display has shown the new interval you should see "END SIA" for about 2 secs.

    Note that if the "Reset" or "Re" does not flash, then you have not met the minimum consumption level and cannot reset.

     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    Bimmer Fan
    Join Date
    Jul 2008
    Location
    Middlesex
    Posts
    11
    Thanks
    1,817
    Thanked 7,115 Times in 5,338 Posts
     
     

  4. The Following User Says Thank You to xXNealXx For This Useful Post:

    Mace (21-05-2011)

  5.  
    #3
    BMW Master
    Car Details
    mrbarry's Car Details
    Model of Car:
    530d
    Year of Manufacture:
    1999
    Transmission Type:
    manual
    Car Body Type:
    touring
    mrbarry's Avatar
    Join Date
    Dec 2008
    Location
    westmidlands
    Posts
    271
    Thanks
    7
    Thanked 57 Times in 47 Posts
    Ah, sorry. My search words must have been totaly wrong when I looked

    I tried tho
     
     

  6.  
    #4
    Bimmer Fan
    Join Date
    Jul 2008
    Location
    Middlesex
    Posts
    11
    Thanks
    1,817
    Thanked 7,115 Times in 5,338 Posts
    No worries Barry...at least you do a search ...can't be said about others though
     
     

  7.  
    #5
    BMW Master
    Car Details
    mrbarry's Car Details
    Model of Car:
    530d
    Year of Manufacture:
    1999
    Transmission Type:
    manual
    Car Body Type:
    touring
    mrbarry's Avatar
    Join Date
    Dec 2008
    Location
    westmidlands
    Posts
    271
    Thanks
    7
    Thanked 57 Times in 47 Posts
    Well anything else I find I will post, even if it is reposts
     
     

  8. 2002 e39 3.0se 
    #6
    Bimmer Fan
    Car Details
    steveoo's Car Details
    Model of Car:
    3.0i se
    Year of Manufacture:
    2002
    Transmission Type:
    steptronic
    Car Body Type:
    saloon

    Join Date
    Mar 2010
    Location
    bradford
    Posts
    18
    Thanks
    1
    Thanked 1 Time in 1 Post
    I know this is an old thread but it was spot on.just reset my service lights
    cheers guys.
     
     

  9. The Following User Says Thank You to steveoo For This Useful Post:

    xXNealXx (17-06-2010)

  10.  
    #7
    Bimmer Fan
    Join Date
    Jul 2008
    Location
    Middlesex
    Posts
    11
    Thanks
    1,817
    Thanked 7,115 Times in 5,338 Posts
    Quote Originally Posted by steveoo View Post
    I know this is an old thread but it was spot on.just reset my service lights
    cheers guys.
    Good to see you used the search function as well
     
     

  11.  
    #8
    Bimmer Fan
    Car Details
    josew's Car Details
    Model of Car:
    323i SE
    Year of Manufacture:
    1999
    Transmission Type:
    Manual
    Car Body Type:
    Saloon

    Join Date
    Oct 2009
    Location
    UK
    Posts
    14
    Thanks
    2
    Thanked 0 Times in 0 Posts
    I'm Hoping someone can help;

    I've just completed an oil change but cannot for the life of me reset my service/oil indicator. I've tried everything, but all I get when I hold the trip reset is the 'test' menu.

    What am I doing wrong

    BMW 323i 10/1999 - OBDII - 16 pin under drivers side
    Last edited by josew; 24-07-2010 at 23:26. Reason: spelling
     
     

  12.  
    #9
    BMW Guru
    Car Details
    shamM3's Car Details
    Model of Car:
    318i
    Year of Manufacture:
    1997
    Transmission Type:
    Manual
    Car Body Type:
    Vert
    shamM3's Avatar
    Join Date
    Aug 2009
    Location
    West Yorkshire
    Posts
    4,071
    Thanks
    950
    Thanked 1,502 Times in 1,391 Posts
    Quote Originally Posted by josew View Post
    I'm Hoping someone can help;

    I've just completed an oil change but cannot for the life of me reset my service/oil indicator. I've tried everything, but all I get when I hold the trip reset is the 'test' menu.

    What am I doing wrong

    BMW 323i 10/1999 - OBDII - 16 pin under drivers side
    You'll need the tool, under £15 on ebay or you can short a pin to ground can't remember which one but at the risk of blowing something
     
     

  13.  
    #10
    Bimmer Fan
    Join Date
    Jul 2008
    Location
    Middlesex
    Posts
    11
    Thanks
    1,817
    Thanked 7,115 Times in 5,338 Posts
    Quote Originally Posted by josew View Post
    I'm Hoping someone can help;

    I've just completed an oil change but cannot for the life of me reset my service/oil indicator. I've tried everything, but all I get when I hold the trip reset is the 'test' menu.

    What am I doing wrong

    BMW 323i 10/1999 - OBDII - 16 pin under drivers side
    The dash method is not going to work because you have an early model which needs to be reset by using the 20 pin connector in the engine bay. The one under the dash has not got full connectivity.
     
     

Page 1 of 2 12 LastLast
Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts