e46 electrical fault. Interior electrics not working

Notices
 

Thread: e46 electrical fault. Interior electrics not working

Reply to Thread
Results 1 to 5 of 5
  1. e46 electrical fault. Interior electrics not working 
    #1
    BMW Fanatic
    Car Details
    ben m's Car Details
    Model of Car:
    320D
    Year of Manufacture:
    2002
    Transmission Type:
    Manual
    Car Body Type:
    Saloon

    Join Date
    May 2012
    Location
    Portsmouth, UK
    Posts
    55
    Thanks
    1
    Thanked 5 Times in 5 Posts
    Afternoon All,

    I have a problem with my interior electrics not working. The only things which work are the window. NAV screen is dead, indicators, etc. etc.

    I got a new battery because I knew mine was poor and thought that might have been the cause but no joy.

    DIS is reporting:

    Xenon - undervoltage term 15 < 7.5 volts
    (left and right side)
    Instrument - BE Kombi: Data-Filling difference to central light module ---- Invalid working
    Instrument - 8C Kombi: Terminal R -- Open Circuit -- Currently Present
    Instrument - 87 Kombi: K Bus -- Short circuit to negative -- currently present



    I know electrics are hard to diagnose remotely but I don't even know where to start. Does anyone have any suggestions?

    I don't know if it is coincidence but last week I noticed my sunroof wasnt working because the fuse was blown. Changed it and it was just instantly blowing again. Things were working after this but then they stopped a few days later. Don't know if it could be linked?

    Also got this when running diagnostics. D-Bus was fine but K-Bus faulty:

     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    BMW Crazed
    Car Details
    P_Monty's Car Details
    Model of Car:
    330Ci Msport
    Year of Manufacture:
    2004
    Transmission Type:
    Manual
    Car Body Type:
    Convertible

    Join Date
    May 2012
    Location
    wiltshire
    Posts
    182
    Images
    3
    Thanks
    16
    Thanked 10 Times in 10 Posts
    Pure guesswork here, but...
    If you pull the fuse that keeps blowing do you get the same errors? I'm guessing that something is drawing current and pulling the voltage low. I'd also check the earths related to the lights...
     
     

  4.  
    #3
    BMW Fanatic
    Car Details
    ben m's Car Details
    Model of Car:
    320D
    Year of Manufacture:
    2002
    Transmission Type:
    Manual
    Car Body Type:
    Saloon

    Join Date
    May 2012
    Location
    Portsmouth, UK
    Posts
    55
    Thanks
    1
    Thanked 5 Times in 5 Posts
    The guitar is blown so wouldn't have thought it makes much difference?

    Sent from my GT-I9505 using Tapatalk 2
     
     

  5. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  6.  
    #4
    BMW Crazed
    Car Details
    P_Monty's Car Details
    Model of Car:
    330Ci Msport
    Year of Manufacture:
    2004
    Transmission Type:
    Manual
    Car Body Type:
    Convertible

    Join Date
    May 2012
    Location
    wiltshire
    Posts
    182
    Images
    3
    Thanks
    16
    Thanked 10 Times in 10 Posts
    True - I missed that - I'd still have a good look at earth around the lights though...
     
     

  7.  
    #5
    BMW Fanatic
    Car Details
    ben m's Car Details
    Model of Car:
    320D
    Year of Manufacture:
    2002
    Transmission Type:
    Manual
    Car Body Type:
    Saloon

    Join Date
    May 2012
    Location
    Portsmouth, UK
    Posts
    55
    Thanks
    1
    Thanked 5 Times in 5 Posts
    Just noticed the spell check fail on my last message! Earth around the lights? I was thinking its to do with the sunroof as that's the fuse which keeps blowing? Figured its all linked to that?

    Sent from my GT-I9505 using Tapatalk 2
     
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts