E46 Door Mirrors+Parking Sencors problems

Notices
 

Thread: E46 Door Mirrors+Parking Sencors problems

Reply to Thread
Page 1 of 2 12 LastLast
Results 1 to 10 of 15
  1. E46 Door Mirrors+Parking Sencors problems 
    #1
    Bimmer Fan
    Car Details
    Matrixiux's Car Details
    Model of Car:
    330Cd
    Year of Manufacture:
    2004
    Transmission Type:
    Automatic
    Car Body Type:
    Coupe

    Join Date
    Jul 2011
    Location
    London
    Posts
    11
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Hi.

    Im new. I have 330CD 2004.

    Problem 1:
    The door mirror "Adjuster" is not working. All fuses are in place, when I go reverse, the left one tilts down, and when I get out of reverse, it goes back up.
    I assume If i flick the switch to the right, It would do that to right one. It doesnt.
    I've done the diagnostics once with some guy. He didnt see any foults, and he managed to control the left mirror with the computer. Cant remember if he could do the same with the right one. Well, he charged me, and he wasnt sure nor clear about all of this. So I never went to him again.
    I took away the inside door cover, to see if there are any loose cables or something, same in the door hinge. Nothing visible. So today Im driving without them adjusters, and with memory seats, the mirrors dont memories either (couse I cant set them).

    Problem 2:
    Revers parking sensor sometimes works like it should, but sometimes it constantly BEEPS, as there would be something dead close. Its all completly random.. This started to occure when I hit other car reversing, at quite some speed.


    Please Help Me.
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    BMW Crazed
    Car Details
    jrfty's Car Details
    Model of Car:
    330ci
    Year of Manufacture:
    2004
    Transmission Type:
    Manual
    Car Body Type:
    Coupe
    jrfty's Avatar
    Join Date
    Apr 2011
    Location
    London
    Posts
    177
    Thanks
    34
    Thanked 80 Times in 61 Posts
    Quote Originally Posted by Matrixiux View Post
    Problem 1:
    The door mirror "Adjuster" is not working. All fuses are in place, when I go reverse, the left one tilts down, and when I get out of reverse, it goes back up.
    I assume If i flick the switch to the right, It would do that to right one. It doesnt.
    The driver side mirror is not meant to auto tilt. Only passenger side has this function. Check your manual, it says it in there. There is nothing wrong with your car
    Eibach Sportline springs, Powerflex bushes, 8.5/9.5 19" Matt black VMR V710s 235/265, Carbon fibre badges, 35% tint all around, black front grille, lamin-x tint film on front and rear lights, 55W 7.5k HIDs, Orion V2 halo LED angel eyes, smoked side markers, keyhole delete, K&N panel filter, private plate, bwchiptune ecu remap.
     
     

  4.  
    #3
    Bimmer Fan
    Car Details
    Matrixiux's Car Details
    Model of Car:
    330Cd
    Year of Manufacture:
    2004
    Transmission Type:
    Automatic
    Car Body Type:
    Coupe

    Join Date
    Jul 2011
    Location
    London
    Posts
    11
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by jrfty View Post
    The driver side mirror is not meant to auto tilt. Only passenger side has this function. Check your manual, it says it in there. There is nothing wrong with your car
    That calms me down, but the problem is, that my adjuster is not working.. I took the mirror part of the mirror to see whats underneath, and I found out that left mirrors has a cut cable. Well the cable is very flat and transperent-like, it ends as 2 pins that go on to the left mirror, to the mirror itself. I assume that is the mirrors heater? As for right mirror, seems well intact. Could that left mirror cable's disconnection affect my adjuster? Also, when left mirror tilts down, it stoped tilting up, unless I help him, then it resumes to reset its previous possition like it should. Any help/Info? :(
     
     

  5. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  6.  
    #4
    Bimmer Fan
    Car Details
    bummer007's Car Details
    Model of Car:
    325ci
    Year of Manufacture:
    2004
    Transmission Type:
    Manual
    Car Body Type:
    Coupe
    bummer007's Avatar
    Join Date
    Dec 2011
    Location
    United Kingdom
    Posts
    15
    Thanks
    4
    Thanked 1 Time in 1 Post
    Quote Originally Posted by Matrixiux View Post
    Hi.

    Im new. I have 330CD 2004.

    Problem 1:
    The door mirror "Adjuster" is not working. All fuses are in place, when I go reverse, the left one tilts down, and when I get out of reverse, it goes back up.
    I assume If i flick the switch to the right, It would do that to right one. It doesnt.
    I've done the diagnostics once with some guy. He didnt see any foults, and he managed to control the left mirror with the computer. Cant remember if he could do the same with the right one. Well, he charged me, and he wasnt sure nor clear about all of this. So I never went to him again.
    I took away the inside door cover, to see if there are any loose cables or something, same in the door hinge. Nothing visible. So today Im driving without them adjusters, and with memory seats, the mirrors dont memories either (couse I cant set them).

    Problem 2:
    Revers parking sensor sometimes works like it should, but sometimes it constantly BEEPS, as there would be something dead close. Its all completly random.. This started to occure when I hit other car reversing, at quite some speed.


    Please Help Me.
    Had exactly the same problem as problem 1 for a while but it has resolved itself now!

    My adjuster wasn't working but the passenger mirror would tilt down when reversing.

    I also realised that if I selected memory recall on my seat, it would adjust my mirrors OK.

    It's stopped this now - I potentially put it down to having some moisture or something in the unit/wiring.

    Perhaps try again in a few days...
     
     

  7.  
    #5
    Bimmer Fan
    Car Details
    Matrixiux's Car Details
    Model of Car:
    330Cd
    Year of Manufacture:
    2004
    Transmission Type:
    Automatic
    Car Body Type:
    Coupe

    Join Date
    Jul 2011
    Location
    London
    Posts
    11
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by bummer007 View Post
    Had exactly the same problem as problem 1 for a while but it has resolved itself now!

    My adjuster wasn't working but the passenger mirror would tilt down when reversing.

    I also realised that if I selected memory recall on my seat, it would adjust my mirrors OK.

    It's stopped this now - I potentially put it down to having some moisture or something in the unit/wiring.

    Perhaps try again in a few days...
    Its nice to know that Im not the only 1 with this problem.. but do you have any solution? Couse this aint random problem.. this problem i have for a year now... maybe something I could try with my memory seats? Couse it all looks too complicated to me the way the mirrors should fold with your seats..

    So how could I test them mirrors out using my memory seats?
     
     

  8.  
    #6
    Bimmer Fan
    Car Details
    Matrixiux's Car Details
    Model of Car:
    330Cd
    Year of Manufacture:
    2004
    Transmission Type:
    Automatic
    Car Body Type:
    Coupe

    Join Date
    Jul 2011
    Location
    London
    Posts
    11
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Bump.. I still have the problem with parking sensors.. I took the bumper off to see if there are any loose connections.. there wasnt.. cables look fine.. then i cleaned the sensor heads as much as I could, still problem occures.. any suggestions?

    And as for mirrors.. i guess there is no solution besides replacing EVERYTHING in that system..
     
     

  9.  
    #7
    sag
    sag is offline
    Bimmer Fan
    Car Details
    sag's Car Details
    Model of Car:
    330d m sport
    Year of Manufacture:
    2003
    Transmission Type:
    automatic
    Car Body Type:
    Saloon

    Join Date
    Feb 2012
    Location
    west yorkshire
    Posts
    10
    Images
    7
    Thanks
    0
    Thanked 1 Time in 1 Post
    hi there
    have you tried putting your ear to each sensor to see if all making a ticking noise?
    i had same problem and when i did that found i had 2 only making slight noise,changed them all ok now.
     
     

  10.  
    #8
    Bimmer Fan
    Car Details
    Matrixiux's Car Details
    Model of Car:
    330Cd
    Year of Manufacture:
    2004
    Transmission Type:
    Automatic
    Car Body Type:
    Coupe

    Join Date
    Jul 2011
    Location
    London
    Posts
    11
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Should I start the car, put the car in reverse gear and pull up the heandbrake and check? And should the noise be at any time? or when the sensor is failing? I will try.
     
     

  11.  
    #9
    BMW Crazed
    Car Details
    jrfty's Car Details
    Model of Car:
    330ci
    Year of Manufacture:
    2004
    Transmission Type:
    Manual
    Car Body Type:
    Coupe
    jrfty's Avatar
    Join Date
    Apr 2011
    Location
    London
    Posts
    177
    Thanks
    34
    Thanked 80 Times in 61 Posts
    Quote Originally Posted by Matrixiux View Post
    Should I start the car, put the car in reverse gear and pull up the heandbrake and check? And should the noise be at any time? or when the sensor is failing? I will try.
    Don't run yourself over!
    Eibach Sportline springs, Powerflex bushes, 8.5/9.5 19" Matt black VMR V710s 235/265, Carbon fibre badges, 35% tint all around, black front grille, lamin-x tint film on front and rear lights, 55W 7.5k HIDs, Orion V2 halo LED angel eyes, smoked side markers, keyhole delete, K&N panel filter, private plate, bwchiptune ecu remap.
     
     

  12.  
    #10
    sag
    sag is offline
    Bimmer Fan
    Car Details
    sag's Car Details
    Model of Car:
    330d m sport
    Year of Manufacture:
    2003
    Transmission Type:
    automatic
    Car Body Type:
    Saloon

    Join Date
    Feb 2012
    Location
    west yorkshire
    Posts
    10
    Images
    7
    Thanks
    0
    Thanked 1 Time in 1 Post
    Dont do it with the engine running just ignition on and handbrake on and in reverse,the noise should be anytime just a little ticking noise if really faint its not working.hope this is ok?
     
     

Page 1 of 2 12 LastLast
Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts