E46 Coupe - Rear Defogger Problem

Notices
 

Thread: E46 Coupe - Rear Defogger Problem

Reply to Thread
Results 1 to 3 of 3
  1. E46 Coupe - Rear Defogger Problem 
    #1
    BMW Fanatic
    Car Details
    azazal23's Car Details
    Model of Car:
    525d E60
    Year of Manufacture:
    2004
    Transmission Type:
    Auto
    Car Body Type:
    Saloon

    Join Date
    Oct 2008
    Location
    Liverpool
    Posts
    45
    Thanks
    0
    Thanked 2 Times in 1 Post
    Only had my motor 2 weeks so bear with me. Rear heated screen doesnt work (is that the defogger) or is that something else? The red light comes on but does not clear the screen. Also when i do that it really interfears with the radio?

    Check the fuse No 68 i think on the panel, are there any more?

    Can anyone give me any pointers to check?


    Cheers
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    Bimmer Fan
    Join Date
    Jul 2008
    Location
    Middlesex
    Posts
    11
    Thanks
    1,817
    Thanked 7,115 Times in 5,338 Posts
    Have a read HERE. Similar problem.
     
     

  4.  
    #3
    BMW Fanatic
    Car Details
    azazal23's Car Details
    Model of Car:
    525d E60
    Year of Manufacture:
    2004
    Transmission Type:
    Auto
    Car Body Type:
    Saloon

    Join Date
    Oct 2008
    Location
    Liverpool
    Posts
    45
    Thanks
    0
    Thanked 2 Times in 1 Post
    OK cheers
     
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts