E46 Climate controls problem

Notices
 

Thread: E46 Climate controls problem

Reply to Thread
Results 1 to 6 of 6
  1. E46 Climate controls problem 
    #1
    Bimmer Fan
    Car Details
    Teza's Car Details
    Model of Car:
    316ti
    Year of Manufacture:
    2003
    Transmission Type:
    Manual
    Car Body Type:
    Compact

    Join Date
    Oct 2008
    Location
    Kent
    Posts
    15
    Thanks
    3
    Thanked 0 Times in 0 Posts
    Not sure if this is in the correct forum?

    I have just bought this car 316i 03 plate E46.
    I am having problems with the climate control/ heater. The previous owner has taken out a 'knob' control system and put the 'button system with centre LCD' control system.

    It works fine, but the air flow direction is completely wrong? it always wants to push the air to the feet vents? and middle vents? it will not push air through the windscreen vent even though i have selected it?

    Is there a chance he has messed up the connectors in the back? or just the units faulty?

    Also can this be done and working correctly? changing the 'knob' control system and put the 'button system with centre LCD' control system in?

    Please help
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    Bimmer Fan
    Join Date
    Jul 2008
    Location
    Middlesex
    Posts
    11
    Thanks
    1,817
    Thanked 7,115 Times in 5,338 Posts
    So what you are saying is that he has put in an auto air con control unit?
     
     

  4.  
    #3
    Bimmer Fan
    Car Details
    Teza's Car Details
    Model of Car:
    316ti
    Year of Manufacture:
    2003
    Transmission Type:
    Manual
    Car Body Type:
    Compact

    Join Date
    Oct 2008
    Location
    Kent
    Posts
    15
    Thanks
    3
    Thanked 0 Times in 0 Posts
    The 'Dials' picture is the current system.

    The 'Climate' picture is the unit i would like to replace it with but airflow will not come out of the windscreen vent, even though it is selected?

    Can these units be changed so simple? after all, all the connectors and wiring is the same?
    Attached Images
     
     

  5. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  6.  
    #4
    Bimmer Fan
    Join Date
    Jul 2008
    Location
    Middlesex
    Posts
    11
    Thanks
    1,817
    Thanked 7,115 Times in 5,338 Posts
    It's good that the previous one was electronic and not cable driven, otherwise I would have been stumped. This means that you have electronic actuators that move the flaps, so before we can try and resolve your issue, can you ask the previous owner if the system was fully working, re:airflow, once he replaced it?
     
     

  7.  
    #5
    Bimmer Fan
    Car Details
    Teza's Car Details
    Model of Car:
    316ti
    Year of Manufacture:
    2003
    Transmission Type:
    Manual
    Car Body Type:
    Compact

    Join Date
    Oct 2008
    Location
    Kent
    Posts
    15
    Thanks
    3
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by NealP View Post
    It's good that the previous one was electronic and not cable driven, otherwise I would have been stumped. This means that you have electronic actuators that move the flaps, so before we can try and resolve your issue, can you ask the previous owner if the system was fully working, re:airflow, once he replaced it?
    Hi neil i have both units now, the dials one works fine [Reinstalled for now] no problems at all, the electronic one with lcd screen i had issues with the airflow control. The airflow wouldnt come out the vents i selected. Seeing that the 'Dials' one works. im guessing the fault is in the 'Climate control unit'?

    Seeing that the cable connectors are the same am I right in thinking that this is possible? and would work? [Given a working climate control unit?]
     
     

  8.  
    #6
    BMW Crazed
    Car Details
    phil si's Car Details
    Model of Car:
    330Ci
    Year of Manufacture:
    2000
    Transmission Type:
    Manual
    Car Body Type:
    Coupe

    Join Date
    Feb 2008
    Location
    rotherham
    Posts
    197
    Thanks
    35
    Thanked 26 Times in 24 Posts
    Hi there did you end up resolving this problem?
     
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts