E46 Climate control not working

Notices
 

Thread: E46 Climate control not working

Reply to Thread
Results 1 to 8 of 8
  1. E46 Climate control not working 
    #1
    Bimmer Fan
    Car Details
    JBrowse's Car Details
    Model of Car:
    316i SE
    Year of Manufacture:
    2001
    Transmission Type:
    Manual
    Car Body Type:
    Saloon

    Join Date
    Jun 2013
    Location
    Paignton, Devon
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I have an E46 316 SE facelift saloon and the climate control doesn't work properly. It only blows hot air no matter what temperature I set it to :( is this a common fault? Everything else works as it should like direction and fan speed it's just the temperature. I have tried a different unit and that doesn't work and now I don't know where to look.
    Can anyone help?

    Cheers


    Sent from AutoGuide.com Free App
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    Bimmer Fan
    Car Details
    JBrowse's Car Details
    Model of Car:
    316i SE
    Year of Manufacture:
    2001
    Transmission Type:
    Manual
    Car Body Type:
    Saloon

    Join Date
    Jun 2013
    Location
    Paignton, Devon
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Please help guys I'm roasting away in this weather and no one seems to know what it is :(


    Sent from AutoGuide.com Free App
     
     

  4.  
    #3
    Moderator
    Car Details
    edber's Car Details
    Model of Car:
    E60 520D LCI
    Year of Manufacture:
    2007
    Transmission Type:
    AUTOMATIC
    Car Body Type:
    saloon
    edber's Avatar
    Join Date
    Mar 2012
    Location
    South ireland
    Posts
    4,964
    Images
    6
    Thanks
    637
    Thanked 689 Times in 646 Posts
    Have you checked the compressor pump clutch,is it engaging?
    Is there enough gas in the system?
    Is the fan working to cool down the condenser?
     
     

  5. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  6.  
    #4
    Bimmer Fan
    Car Details
    JBrowse's Car Details
    Model of Car:
    316i SE
    Year of Manufacture:
    2001
    Transmission Type:
    Manual
    Car Body Type:
    Saloon

    Join Date
    Jun 2013
    Location
    Paignton, Devon
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I'm not sure it wakes a funny noise when I turn on the AC but even at 16 degrees it blows out boiling hot air like its on 30 degrees


    Sent from AutoGuide.com Free App
     
     

  7.  
    #5
    Bimmer Fan
    Car Details
    JBrowse's Car Details
    Model of Car:
    316i SE
    Year of Manufacture:
    2001
    Transmission Type:
    Manual
    Car Body Type:
    Saloon

    Join Date
    Jun 2013
    Location
    Paignton, Devon
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Makes*


    Sent from AutoGuide.com Free App
     
     

  8.  
    #6
    BMW Crazed
    Car Details
    Jasoon's Car Details
    Model of Car:
    318i SE
    Year of Manufacture:
    2002
    Transmission Type:
    Manual
    Car Body Type:
    Saloon

    Join Date
    Sep 2012
    Location
    Cumbria
    Posts
    139
    Thanks
    4
    Thanked 12 Times in 12 Posts
    JBrowse

    you have got the chillier button (snow flake symbol)on?
    If I don't have it on and its set to 16oC it will blow hot air out as its trying to cool the car
     
     

  9.  
    #7
    Moderator
    Car Details
    edber's Car Details
    Model of Car:
    E60 520D LCI
    Year of Manufacture:
    2007
    Transmission Type:
    AUTOMATIC
    Car Body Type:
    saloon
    edber's Avatar
    Join Date
    Mar 2012
    Location
    South ireland
    Posts
    4,964
    Images
    6
    Thanks
    637
    Thanked 689 Times in 646 Posts
    You need to make sure the snowflake button lights up green,
    then you need to see is the compressor clutch engaging,
    then you need to see is the cooling fan coming on.
    Also make sure the center vent is at 3 blue dots for maximum cold.
    Could also be your water valve is bad allowing hot water into the heater matrix.
    If everything on the a/c system checks out ok then id be looking at the water valve or the fuse for the water valve.
     
     

  10.  
    #8
    BMW Fanatic
    Car Details
    mikeaj's Car Details
    Model of Car:
    750
    Year of Manufacture:
    1999
    Transmission Type:
    auto
    Car Body Type:
    saloon

    Join Date
    May 2012
    Location
    Rugby
    Posts
    68
    Thanks
    8
    Thanked 6 Times in 6 Posts
    Check the water valve.
    If the solenoid(s) inside sticks then it usually sticks open letting hot air through the heater as though it's on "max heat". If the pipes are hot when the heater is set to cold, then that's a good possibility.
    It is important to make a second check then. Unplug the valve and check that there are volts on the plug. Volts close the valve (cold air), 0 volts opens the valve (hot air). If there are volts and the valve is open, then it's either stuck or wiring broken inside. I have successfully fixed both several times. Sometimes a sharp tap will loosen it temporarily.
    Twice (E36 320 and E34 530) mine stuck open in Southern Spain! Not funny!
    Mike
     
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts