E39 electrical problem

Notices
 

Thread: E39 electrical problem

Reply to Thread
Results 1 to 4 of 4
  1. E39 electrical problem 
    #1
    Bimmer Fan
    Car Details
    donw23255's Car Details
    Model of Car:
    530d
    Year of Manufacture:
    2000
    Transmission Type:
    Manual
    Car Body Type:
    Saloon

    Join Date
    Jun 2012
    Location
    Norwich
    Posts
    1
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Please could someone help.
    Driving home the other day I noticed the clock on my radio was not working then turning into my drive I saw that the dashboard indicator lights were not working but the actual indicator lights were. The next morning I found the battery was flat. My neighbour jump started my car and after a 30 min drive the battery was fully charged again but still had the same dash problems and also the central locking would not work from the remote key. The next morning the battery was flat again.
    Any help would be greatly appreciated
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    Super Moderator
    Car Details
    payno's Car Details
    Model of Car:
    M3 Evo S Type R
    Year of Manufacture:
    1998 2003
    Transmission Type:
    Manual Auto
    Car Body Type:
    Coupe Saloon
    payno's Avatar
    Join Date
    Feb 2011
    Location
    birmingham city
    Posts
    9,210
    Thanks
    2,081
    Thanked 2,053 Times in 1,891 Posts
    first off you need to have the alternator tested and if that is ok then you need an auto electrician to find a parasitic drain
     
     

  4.  
    #3
    BMW Maestro
    Car Details
    danidge's Car Details
    Model of Car:
    E36 323i + cbr1000rr
    Year of Manufacture:
    98 + 04
    Transmission Type:
    Manual
    Car Body Type:
    Coupe
    danidge's Avatar
    Join Date
    Nov 2011
    Location
    felixstowe
    Posts
    718
    Thanks
    42
    Thanked 152 Times in 143 Posts
    Quote Originally Posted by payno View Post
    first off you need to have the alternator tested and if that is ok then you need an auto electrician to find a parasitic drain
    the alternator would be working if after jump starting he is able to drive for 30 minutes.

    does sound like its going to be a tricky one to diagnose if you not very handy with a multimeter.
    might be worth having a look around to see if you can see any suspicious wiring faults.
     
     

  5. The Following User Says Thank You to danidge For This Useful Post:

    donw23255 (01-07-2012)

  6. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  7.  
    #4
    Bimmer Fan
    Car Details
    RustyMsport's Car Details
    Model of Car:
    530 Diesel Msport
    Year of Manufacture:
    2001
    Transmission Type:
    Manual
    Car Body Type:
    Saloon

    Join Date
    Jul 2012
    Location
    Formby
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hi did you get your fault sorted I am having the same problem cheers russ
     
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts