E36- Dead Instrument cluster

Notices
 

Thread: E36- Dead Instrument cluster

Reply to Thread
Results 1 to 8 of 8
  1. E36- Dead Instrument cluster 
    #1
    Bimmer Fan
    Car Details
    Hardgraf's Car Details
    Model of Car:
    316se
    Year of Manufacture:
    1997
    Transmission Type:
    Manual
    Car Body Type:
    Saloon

    Join Date
    Mar 2009
    Location
    Bristol
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hello. Bought a E36 316i today and just realised that the speedo, Rev counter & petrol guage etc is dead. The instrument panel is lit & everything else works fine.

    Is this normally a simple fuse fix or is there more too it?

    Thanks
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    BMW Maestro
    Car Details
    mikesmith2's Car Details
    Model of Car:
    520i SE
    Year of Manufacture:
    2002
    Transmission Type:
    Auto
    Car Body Type:
    Touring

    Join Date
    Feb 2009
    Location
    Reading.
    Posts
    540
    Thanks
    50
    Thanked 83 Times in 74 Posts
    It's possilbly a bad connection on the back of the cluster.

    But check fuses first.
     
     

  4.  
    #3
    Bimmer Fan
    Car Details
    Hardgraf's Car Details
    Model of Car:
    316se
    Year of Manufacture:
    1997
    Transmission Type:
    Manual
    Car Body Type:
    Saloon

    Join Date
    Mar 2009
    Location
    Bristol
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Great cheers for that

    Also the heater fan is dead. Doesn't blow at all. Normally fan speed regulator?

    Thanks,
    Tom
     
     

  5. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  6.  
    #4
    Dr of BMW gildersol's Avatar
    Join Date
    May 2008
    Location
    scotland
    Posts
    1,423
    Thanks
    171
    Thanked 428 Times in 356 Posts
    Does the blower not work on any speed? Could be fuse 20 or the blower relay
     
     

  7.  
    #5
    Bimmer Fan
    Car Details
    Hardgraf's Car Details
    Model of Car:
    316se
    Year of Manufacture:
    1997
    Transmission Type:
    Manual
    Car Body Type:
    Saloon

    Join Date
    Mar 2009
    Location
    Bristol
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts
    No blower at all. Checked fuse 20 which is fine. Fuses fine for instrument cluster too.

    So would you recommend that I try to fit a new blower motor for the heater?

    Worth installing a replacement instrument cluster?

    Thanks
     
     

  8.  
    #6
    RYM
    RYM is offline
    Legendary BFuk Member
    Car Details
    RYM's Car Details
    Model of Car:
    325tds
    Year of Manufacture:
    1996
    Transmission Type:
    Manual
    Car Body Type:
    Touring
    RYM's Avatar
    Join Date
    Apr 2008
    Location
    Bristol
    Posts
    12,959
    Thanks
    5,540
    Thanked 4,935 Times in 3,119 Posts
    Quote Originally Posted by Hardgraf View Post
    No blower at all. Checked fuse 20 which is fine. Fuses fine for instrument cluster too.

    So would you recommend that I try to fit a new blower motor for the heater?

    Worth installing a replacement instrument cluster?

    Thanks
    Sounds like the instrument cluster may be dead
     
     

  9.  
    #7
    Dr of BMW gildersol's Avatar
    Join Date
    May 2008
    Location
    scotland
    Posts
    1,423
    Thanks
    171
    Thanked 428 Times in 356 Posts
    I would at least check the connections at the rear of the cluster first.
    As for the blower, you need to determine if the relay is working first.
    If you look in the fusebox from the nearside wing it's the second row up, farthest right relay IIRC.
    You don't need to touch the heater controls, just switch on the ignition and listen/feel if the relay clicks.
    Last edited by gildersol; 27-03-2009 at 15:41.
     
     

  10.  
    #8
    Bimmer Fan
    Car Details
    Hardgraf's Car Details
    Model of Car:
    316se
    Year of Manufacture:
    1997
    Transmission Type:
    Manual
    Car Body Type:
    Saloon

    Join Date
    Mar 2009
    Location
    Bristol
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Great, thanks for all your help guys.
     
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts