E36 Alternator Issue

Notices
 

Thread: E36 Alternator Issue

Reply to Thread
Results 1 to 2 of 2
  1. E36 Alternator Issue 
    #1
    Bimmer Fan
    Car Details
    bkazour's Car Details
    Model of Car:
    316i
    Year of Manufacture:
    1997
    Transmission Type:
    Manual
    Car Body Type:
    Saloon

    Join Date
    Nov 2012
    Location
    Lebanon
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hello,
    I have had some funny issue lately that i would like to get an opinion on. I have a 316i 1997 manual.
    Saturday, after a long drive, my battery indicator turned on at 9 PM. i passed by an autoshop and changed the battery, while returning home the battery light remained on.
    I went on Sunday morning, tested the battery while the car was off, the voltage was 12.07 V. I turned on the car, the battery voltage is 13.7 V. I checked the battery light and was surprised that it has turned off.

    I drove it all day on Sunday and Monday, everything was normal except that car idling while switching gear or when stuck in traffic was not stable, toggling between almost 0 and 1. Yesterday night where the light turned back on and the idling issue stopped. I checked the battery voltage while the car was ON and it was around 11.8 V.

    Do you think this is an alternator issue and i should replace it ? or could it be something else.
    Would appreciate any feedback
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    Super Moderator
    Car Details
    payno's Car Details
    Model of Car:
    M3 Evo S Type R
    Year of Manufacture:
    1998 2003
    Transmission Type:
    Manual Auto
    Car Body Type:
    Coupe Saloon
    payno's Avatar
    Join Date
    Feb 2011
    Location
    birmingham city
    Posts
    9,210
    Thanks
    2,081
    Thanked 2,054 Times in 1,892 Posts
    Quote Originally Posted by bkazour View Post
    I checked the battery voltage while the car was ON and it was around 11.8 V
    you should be seeing at least 14.4v with the engine running
    Quote Originally Posted by bkazour View Post
    Do you think this is an alternator issue and i should replace it ?
    yes
     
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts