E36 325TDS Instrument Pod Problem

Notices
 

Thread: E36 325TDS Instrument Pod Problem

Reply to Thread
Results 1 to 3 of 3
  1. E36 325TDS Instrument Pod Problem 
    #1
    BMW Fanatic
    Car Details
    keefy's Car Details
    Model of Car:
    325 tds/328ise/m3 evo
    Year of Manufacture:
    1997/1998/1999
    Transmission Type:
    auto/auto/smg
    Car Body Type:
    saloon/saloon/coupe

    Join Date
    Jun 2009
    Location
    West Sussex
    Posts
    30
    Thanks
    0
    Thanked 5 Times in 3 Posts
    I wonder if anyone else has ever come across this problem

    In the last couple of weeks the instrument pod has started "cutting out" u can be driving along or sitting still there is no routine to when it happens except that its happening more and more.

    When i say cutting out, everything on the dash shuts off, rev counter, speedo, fuel guage, temp guage, economy thing at the bottom, the dash illumination still works ok though.

    It can go off for a couple of seconds or maybe a few minutes.

    The other weird thing is that when it goes off the illumination on the obc goes really bright

    Any help or advice would be really appreciated and tia folks :-)
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    BMW Guru
    Car Details
    billywhizz1984's Car Details
    Model of Car:
    E36 323i x 3, 325TDS x 1, 320i x 2, 318is x 1
    Year of Manufacture:
    1999 x 2, 1998, 1997 x 2, 1996, 1995
    Transmission Type:
    Manual, Auto, Auto, Manual, Auto, Auto, Manual
    Car Body Type:
    Touring x 4, Convertible x 2, Coupe x 1
    billywhizz1984's Avatar
    Join Date
    Sep 2009
    Location
    North East
    Posts
    2,493
    Images
    4
    Thanks
    165
    Thanked 933 Times in 703 Posts
    Commonly reported issue, some seems to link it to voltage stabiliser, however there is no specific fix I'm aware of. Most just replace.
     
     

  4.  
    #3
    BMW Fanatic
    Car Details
    keefy's Car Details
    Model of Car:
    325 tds/328ise/m3 evo
    Year of Manufacture:
    1997/1998/1999
    Transmission Type:
    auto/auto/smg
    Car Body Type:
    saloon/saloon/coupe

    Join Date
    Jun 2009
    Location
    West Sussex
    Posts
    30
    Thanks
    0
    Thanked 5 Times in 3 Posts
    thx m8, had a good read round and it seems the whole pod is a bit of a known issue (unknown to me til earlier lol) with being intermittent and complete failure, so gonna head on over to ebay

    thx again m8
     
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts