E30 Autobox elecrical fault

Notices
 

Thread: E30 Autobox elecrical fault

Reply to Thread
Results 1 to 2 of 2
  1. E30 Autobox elecrical fault 
    #1
    Bimmer Fan
    Car Details
    jamie.h's Car Details
    Model of Car:
    e30
    Year of Manufacture:
    1989
    Transmission Type:
    automatic
    Car Body Type:
    touring

    Join Date
    Aug 2008
    Location
    England
    Posts
    18
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hi Fellow Forum Users,

    I've got a problem with the switch for sports,economy,321 on my E30 2.0i Touring autobox. When I purchased the car in April the switch on the gearbox would only sit in economy, so two weeks ago I brought a new switch from BMW, fitted it and it lasted 10 days before it packed up like the previous one, aaahh!! The clicker has packed up so again it will only sit in economy I've spoke to a mate who is a mechanic and he thinks it's some kind of electrical fault burning out the switch.

    I have posted this thread on the E30 section and followed advice to find a good auto sparky, I've spent the whole of this afternoon ringing round and no one locally seems to be able to help but they have all given suggestions of what it could be but I still have no end result. Does anybody have any ideas of what could be the fault? Has anybody experienced this kind of problem with their E30? Any further help or advice would be much appreciated.

    Regards

    Jamie
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    Bimmerforums Central
    Car Details
    Boostist's Car Details
    Model of Car:
    E46 320i
    Year of Manufacture:
    2001
    Transmission Type:
    Manual
    Car Body Type:
    Coupe
    Boostist's Avatar
    Join Date
    Sep 2004
    Location
    Uk
    Posts
    8,035
    Thanks
    3,347
    Thanked 3,427 Times in 1,481 Posts
    Not sure if this is any help as I didnt search it for long but it will probably have the info in there....

    E30 haynes manual

    This is not a problem I have heard about but if you try posting about it here

    e30 trans forum the guys may well have seen it before?

    I would say firstly you need to get the wiring diagrams for the car. Do you have them by any chance?
    its definately a surge of some sort that is causing it...It 'might' be worth getting the fault codes read but Im not sure if transmission faults will show
     
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts