Do the injectors on a e36 316 have a fuse?

Notices
 

Thread: Do the injectors on a e36 316 have a fuse?

Reply to Thread
Results 1 to 5 of 5
  1. Do the injectors on a e36 316 have a fuse? 
    #1
    Bimmer Fan
    Car Details
    randyandy11600's Car Details
    Model of Car:
    316i
    Year of Manufacture:
    1997
    Transmission Type:
    manual
    Car Body Type:
    saloon

    Join Date
    May 2013
    Location
    Worcester
    Posts
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts
    My car discided to only run on 2 cylinders yesterday, I have checked the spark, timing etc and also swaped the injectors over... And I have found that cylinders 2 & 4 the injectors are not getting any power at all.
    I did change the battery before I started it maybe something has packed up or a fuse popped?

    Any help would be great full
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    BMW Guru
    Car Details
    TheEnd's Car Details
    Model of Car:
    540
    Year of Manufacture:
    1998
    Transmission Type:
    Auto
    Car Body Type:
    Saloon
    TheEnd's Avatar
    Join Date
    Jun 2010
    Location
    Birmingham
    Posts
    8,981
    Thanks
    478
    Thanked 2,990 Times in 2,440 Posts
    They won't have a fuse for them, but they might both work from the same part of the ignition coil.
    If you have an electric brick bolted in the engine bay for your sparkplug wires, it might be that which has the problem.
     
     

  4.  
    #3
    Bimmer Fan
    Car Details
    randyandy11600's Car Details
    Model of Car:
    316i
    Year of Manufacture:
    1997
    Transmission Type:
    manual
    Car Body Type:
    saloon

    Join Date
    May 2013
    Location
    Worcester
    Posts
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Sparks not the problem, the injectors are not gettin any power to them....or is it timed off the coil pack?
     
     

  5. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  6.  
    #4
    BMW Guru
    Car Details
    TheEnd's Car Details
    Model of Car:
    540
    Year of Manufacture:
    1998
    Transmission Type:
    Auto
    Car Body Type:
    Saloon
    TheEnd's Avatar
    Join Date
    Jun 2010
    Location
    Birmingham
    Posts
    8,981
    Thanks
    478
    Thanked 2,990 Times in 2,440 Posts
    Sorry, my fault, I didn't read it properly.

    No fuses for the injectors either, but it does sound like either the wiring to them has been damaged, or there is an ECU fault.
     
     

  7.  
    #5
    Bimmer Fan
    Car Details
    randyandy11600's Car Details
    Model of Car:
    316i
    Year of Manufacture:
    1997
    Transmission Type:
    manual
    Car Body Type:
    saloon

    Join Date
    May 2013
    Location
    Worcester
    Posts
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Thought soo, I'm waiting for an adapter so I can plug the computer at work in
    see wot that brings up!!
     
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts