Connected jump leads up wrong

Notices
 

Thread: Connected jump leads up wrong

Reply to Thread
Results 1 to 2 of 2
  1. Connected jump leads up wrong 
    #1
    Bimmer Fan
    Car Details
    Daz76's Car Details
    Model of Car:
    330i Sport
    Year of Manufacture:
    2003
    Transmission Type:
    Automatic
    Car Body Type:
    Saloon

    Join Date
    Jul 2012
    Location
    Aberdeen
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Was late picking up the kids, went to start the car (e46 330i) and the battery was flat (kids keep switching on the rear lights when getting out of the car ).

    Anyway in my haste I connected the jump leads up wrong , went to start the car and there was no display on the dash went back to the doner vehicle and the battery was smoking.

    Connected things up correctly & got the car started, seems to be running ok but am I liable to have done any damage?

    It was a decent set of leads with a yellow plug and socket connection in the middle which apparently provides surge protection, hoping this may have saved the car from any damge
    Last edited by Daz76; 05-10-2012 at 21:08.
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    BMW Fanatic
    Car Details
    BMWNICK's Car Details
    Model of Car:
    320ci
    Year of Manufacture:
    2001
    Transmission Type:
    Manual
    Car Body Type:
    Coupe

    Join Date
    Jul 2011
    Location
    London
    Posts
    36
    Thanks
    0
    Thanked 7 Times in 7 Posts
    If your car is running ok now then you are fine. I hope the donor vehicle is also ok, although as the battery was smoking you may have damaged that. Just don't do it again...
     
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts