Climate control problem

Notices
 

Thread: Climate control problem

Reply to Thread
Results 1 to 3 of 3
  1. Climate control problem 
    #1
    Bimmer Fan
    Car Details
    Karlos75's Car Details
    Model of Car:
    528i M Sport
    Year of Manufacture:
    2000
    Transmission Type:
    Automatic
    Car Body Type:
    Saloon

    Join Date
    Dec 2012
    Location
    Yorkshire
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hi all,

    I have an intermitant fault with the climate control panel, it all lights up fine but from time to times it doesn't matter what button you press nothing works even though all the lights and display tell you otherwise. It's like you press the button and the signals are not going though, I'm guessing it's just the panel that's starting to break becasue when I loose the ability to alter air flow ect ect ect, the heater rear window stops working too as this in on the same panel.
    I've tested the relay for the Heated Rear window and FSU isn't the issue.

    Are there anyother components for the climate control hiding in the bowels of the car, say for example some relays on the bulk head that could be getting wet if I have a leek in the windscreen I dont know about.

    I read all the car's code and nothing came back relating the HVAC, only codes I received were for a knacked bulb, occupancy sensor and a freez frame which was showing CO2 readings - likely due to it's getting close to a service.

    Thanks for reading

    ps The car is a e39 528i 2000
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    Bimmer Fan
    Car Details
    RUDDO87's Car Details
    Model of Car:
    1 series
    Year of Manufacture:
    2006
    Transmission Type:
    MT
    Car Body Type:
    Hatch

    Join Date
    Nov 2012
    Location
    Hartlepool
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Did you get this problem sorted mate ? i have a simlar problem with my 1 series e87, my AC vents dont move, no matter what button i press nothing happens..
     
     

  4.  
    #3
    Bimmer Fan
    Car Details
    Karlos75's Car Details
    Model of Car:
    528i M Sport
    Year of Manufacture:
    2000
    Transmission Type:
    Automatic
    Car Body Type:
    Saloon

    Join Date
    Dec 2012
    Location
    Yorkshire
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Good evening,

    Yes ths problem is now fixed, Ive swapped the whole panel took about 10 mins to do and its fine. If yours is like mine the panel would give you the impression that it working fine but if you pressed anything nothing was happening. The fsu after checking wiring is just a plain and simple fan motor relay. It does recvive signals from the climate panel to alter the fan speed, I paid £20 for the panel I wouldn't pay much more. You might need to have yours coded if my car was newer Id have had to use the software to code it.
    Hope that helps
     
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts