BMW Z4 (2004) - Roof, Wipers, Windows won't operate after jump start & Radio says 'Disabled'

Notices
 

Thread: BMW Z4 (2004) - Roof, Wipers, Windows won't operate after jump start & Radio says 'Disabled'

Reply to Thread
Results 1 to 2 of 2
  1. BMW Z4 (2004) - Roof, Wipers, Windows won't operate after jump start & Radio says 'Disabled' 
    #1
    Bimmer Fan
    Car Details
    Charlie_1's Car Details
    Model of Car:
    Z4
    Year of Manufacture:
    2004
    Transmission Type:
    Manual
    Car Body Type:
    Coupe

    Join Date
    Apr 2013
    Location
    Clare
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hi Folks,

    My wife's Z4 had been sitting idle for a number of weeks without being driven. Yesterday I went to start the car but it was completely dead. It was obvious the battery was dead because the starter was not even clicking and dash board was dead.
    I jump started the car as normal via the battery connectors in the rear boot area and the car started.

    I turned it off and tried to start it again after a couple of minutes but it was again dead. I jumped started it again and left it running. All appeared to be fine apart from the fact that...

    1. The windows are not working.
    2. The Airbag red light is showing as red on the Dashboard.
    3. The Soft top will not work.

    I checked each fuse and all seemed fine. I did notice that when I remove the fuse in the number 10 slot and replaced it, the window on the passenger side moved slightly down each time. Not sure why.

    Any idea's what the issue is and how I can resolve same? Have I inadvertantly fried something?

    Thanks

    Keith
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    BMW Fanatic
    Car Details
    mikeaj's Car Details
    Model of Car:
    750
    Year of Manufacture:
    1999
    Transmission Type:
    auto
    Car Body Type:
    saloon

    Join Date
    May 2012
    Location
    Rugby
    Posts
    68
    Thanks
    8
    Thanked 6 Times in 6 Posts
    Radio is the "give-away". Something is not happy on the can-bus circuit that controls those electrics, and it's pulling the circuit down. My daughter's fiancee has an e46 which had no radio. It flashed "disabled" and wouldn't switch on. Turned out to be connection to tweeter speaker in drivers door. Logical? Drove me mad for weeks disconnecting things.
    It's worth running in for GOOD diagnostics i.e. can-bus capable, if you don't have the kit.
    Mike
     
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts