BMW E65 loss of power

Notices
 

Thread: BMW E65 loss of power

Reply to Thread
Results 1 to 8 of 8
  1. BMW E65 loss of power 
    #1
    Bimmer Fan
    Car Details
    irgi.hasa's Car Details
    Model of Car:
    730D
    Year of Manufacture:
    2006
    Transmission Type:
    Automatic
    Car Body Type:
    Saloon

    Join Date
    Jan 2014
    Location
    Manchester
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hello, i am new to this forum and I know they have expert advice here. i have a a BMW 730D e65 2006 model and i have loss of power. At first i thought it might be the DPF FILTER, so i went on a motorway and cleared it completely, after a few days my car has started to loose power again and and i am loosing more power everyday. Can anyone please help me on this?


    Sent from AutoGuide.com Free App
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    BMW Fanatic
    Car Details
    eshaffu's Car Details
    Model of Car:
    730d
    Year of Manufacture:
    2006
    Transmission Type:
    Automatic
    Car Body Type:
    saloon

    Join Date
    Jun 2008
    Location
    Leicester
    Posts
    74
    Thanks
    18
    Thanked 2 Times in 2 Posts
    Hi. I'm having the same issue as you. Same year and engine 730d. Loss of power especially at higher speeds and getting worse. If anyone can help us that would be great.
     
     

  4.  
    #3
    Super Moderator
    Car Details
    payno's Car Details
    Model of Car:
    M3 Evo S Type R
    Year of Manufacture:
    1998 2003
    Transmission Type:
    Manual Auto
    Car Body Type:
    Coupe Saloon
    payno's Avatar
    Join Date
    Feb 2011
    Location
    birmingham city
    Posts
    9,224
    Thanks
    2,085
    Thanked 2,055 Times in 1,893 Posts
    the car needs to have diagnostics run on it
     
     

  5. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  6.  
    #4
    BMW Fanatic
    Car Details
    eshaffu's Car Details
    Model of Car:
    730d
    Year of Manufacture:
    2006
    Transmission Type:
    Automatic
    Car Body Type:
    saloon

    Join Date
    Jun 2008
    Location
    Leicester
    Posts
    74
    Thanks
    18
    Thanked 2 Times in 2 Posts
    Hi. With mine it is turning out to be a blocked dpf.
     
     

  7.  
    #5
    BMW Master
    Car Details
    gunslinger1's Car Details
    Model of Car:
    company car
    Year of Manufacture:
    company car
    Transmission Type:
    company car
    Car Body Type:
    company car

    Join Date
    Jan 2013
    Location
    midlands
    Posts
    351
    Thanks
    0
    Thanked 24 Times in 23 Posts
    eshaffu, how do you know you cleared it completley . do you know it went in to regeneration mode ? , if so how ?
     
     

  8.  
    #6
    BMW Fanatic
    Car Details
    eshaffu's Car Details
    Model of Car:
    730d
    Year of Manufacture:
    2006
    Transmission Type:
    Automatic
    Car Body Type:
    saloon

    Join Date
    Jun 2008
    Location
    Leicester
    Posts
    74
    Thanks
    18
    Thanked 2 Times in 2 Posts
    the garage said it is failing to regenerate as it has blocked up a lot. I'm at a loose end to be honest. Anyone in Leicester with OBD diagnostics?
     
     

  9.  
    #7
    BMW Master
    Car Details
    Bmw techy's Car Details
    Model of Car:
    325ci
    Year of Manufacture:
    2001
    Transmission Type:
    Manual
    Car Body Type:
    Coupe

    Join Date
    Nov 2009
    Location
    westmidlands
    Posts
    317
    Thanks
    2
    Thanked 84 Times in 70 Posts
    Even if its seriously blocked you can still force regen it, with the right know-how and equipment. main reason we see for blocking up is thermostats failed.
    Mr BMW Tech
     
     

  10.  
    #8
    BMW Fanatic
    Car Details
    eshaffu's Car Details
    Model of Car:
    730d
    Year of Manufacture:
    2006
    Transmission Type:
    Automatic
    Car Body Type:
    saloon

    Join Date
    Jun 2008
    Location
    Leicester
    Posts
    74
    Thanks
    18
    Thanked 2 Times in 2 Posts
    Main thermostat is ok as coolant temp is going up 89 degrees on a run. Am going to replace the egr thermostat. I tried to do this today but couldn't move the vacuum hose near it to gain access to one if the bolts holding the egr thermostat into place. Frustrating. Going to the garage tomorrow to see if they can sort it out.
     
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts