BMW 320d E90 Non starter after full engine rebuild

Notices
 

Thread: BMW 320d E90 Non starter after full engine rebuild

Reply to Thread
Results 1 to 3 of 3
  1. BMW 320d E90 Non starter after full engine rebuild 
    #1
    Bimmer Fan
    Car Details
    samf1988's Car Details
    Model of Car:
    320d
    Year of Manufacture:
    2007
    Transmission Type:
    Manual
    Car Body Type:
    Saloon

    Join Date
    Jan 2017
    Location
    Birmingham
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hi all,

    I am a new to forum and am seeking some assistance to a fault that is really starting to puzzle me.
    I have good understanding of mechanical and electrical systems on cars but now sit behind a desk full time and do this as a Hobby, if you like.

    I recently purchased a 320d E90 SE for a reasonable price with a blown engine, Long story short it missed a few oil changes and melted the Piston rings to the Block and ejected the front shells out the front of the engine. £1200 later i have a fully rebuilt engine back in that refuses to start. Compression test done and all okay.

    At first i believed that the crank sensor was a fault, which has now been replaced and has had no further avail. (Don't Start)

    The engine cranks over fast and i have fuel at the injectors. All 4 have been bled but do not seem to fire.

    I have tested the OBD port and have found that i do have two earths, a battery voltage 12.5v and the high 2.9v and low 2.1v speed CAN Pins are also reading.

    With the ignition on a can here the fuel pump constantly priming and does not seem to shut off. Only with the ignition on tho, cannot tell whilst it is cranking over.

    All cables have been reconnected but i cannot connect my OBD scanner to the car. Just says No Communication. I have tried 3 separate scanners and all have failed to connect.
    A sealey handheld
    A snap-on Ultra
    Cheapo Chinese handheld.

    Anyone ever come across this before and if so any ideas? I am thinking i could check the DDE relay but cannot find a wiring diagram anywhere.

    All seems alot to take in but i have had many late nights staring at this car now and want to drive the car.

    Any ideas
    Thanks Guys & Girls

    Sam :)
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    Authorised Bimmerforums UK Vendor
    Car Details
    bwchiptune's Car Details
    Model of Car:
    x5
    Year of Manufacture:
    2002
    Transmission Type:
    auto
    Car Body Type:
    estate
    bwchiptune's Avatar
    Join Date
    Jan 2010
    Location
    Hayes west london UB3 1BB
    Posts
    2,725
    Thanks
    59
    Thanked 282 Times in 249 Posts
    I get loads of cars that have just had a engine rebuild from these engine companies and everyone has needed a Ecu and has been the reason it didn't start in the 1st place

    Who rebuilt your engine ?
    Have you check your Ecu for water damage


    BW chiptune
    Tuning BMWs since 1991
    BW autorepairs
    Over 30 year repairing BMWs
    New and fully refurbished BMW Ecus
    0208 561 1818
    07831 103030
    Hayes
    UB3 1BB

    PERFORMANCE ECU TUNING(ALL CARS)FOR Bimmerforums MEMBERS
    CHIPPING AND REMAPPING
    Dyno Dynamics Rolling Road
    WORKSHOP REPAIRS(BMW,AUDI,VW,VAG,MERCS)
    TURBO,SUPERCHARGER TUNING
    ENGINE TRANSPLANT ECU CONVERSIONS
    CODING & PROGRAMMING,
    ECU REPAIRS & DPF,CAT REMOVAL
    REMAPPING TOOLS AND TUNED FILES AVAILABLE
    M5 F10 M6 F12/13 REMAPS £699
    WE HAVE NOW MOVED TO HAYES UB3 1BB
    www.bwchiptune.co.uk
    www.bwautorepairs.co.uk
    www.tuningtools.co.uk
    +44(0)7831 10 30 30
    +44(0)208 561 18 18
     
     

  4.  
    #3
    Bimmer Fan
    Car Details
    samf1988's Car Details
    Model of Car:
    320d
    Year of Manufacture:
    2007
    Transmission Type:
    Manual
    Car Body Type:
    Saloon

    Join Date
    Jan 2017
    Location
    Birmingham
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hi Chiptune,

    I rebuilt the engine myself in my Garage with reground crank, new shells, timing chain and all gaskets.
    Last night i got hold of Autodata and tested for power at the DDE and found no power there. I fault turned out to be the DDE relay. I just was not there. I'm guessing the previous owner has removed to immobilise the car.

    So if anyone has ann issue with non start i recommend the check that you have power at the DDE relay and that it is functioning correctly. You can do this with a multi meter. I have some pictures of the pin data from auto data which i will attach later today.

    My engine was the N47D20A

    BMW 320d SE 2007

    Thank you for your reply.
     
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts